diff mbox series

[bug#42170] gnu: Add emacs-org-beautify-theme.

Message ID DM5PR1001MB210503FE5C80E22F0AA438B8C56A0@DM5PR1001MB2105.namprd10.prod.outlook.com
State Accepted
Headers show
Series [bug#42170] gnu: Add emacs-org-beautify-theme. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Morgan Smith July 3, 2020, 3:24 a.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-org-beautify-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Nicolas Goaziou July 3, 2020, 10:31 p.m. UTC | #1
Hello,

Morgan.J.Smith@outlook.com writes:

> * gnu/packages/emacs-xyz.scm (emacs-org-beautify-theme): New variable.

Thank you. 

I fixed indentation, added a comment explaining why we don't use
a specific tag, slightly fixed description, and committed your patch.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1941379dea..c435e312b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -76,6 +76,7 @@ 
 ;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
 ;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
 ;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23403,3 +23404,24 @@  easily.  Four pre-set options are: @samp{shell}, @samp{terminal},
 @samp{ansi-term}, and @samp{eshell}.  You can also set your custom shell if
 you use some other configuration.")
       (license license:gpl3+))))
+
+(define-public emacs-org-beautify-theme
+  (package
+   (name "emacs-org-beautify-theme")
+   (version "0.4")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/jonnay/org-beautify-theme")
+                  (commit "df6a1114fda313e1689363e196c8284fbe2a2738")))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "1lkz7736swimad12khwbbqc4gxjydgr1k45p4mx03s25pv1w920y"))))
+   (build-system emacs-build-system)
+   (home-page "https://github.com/jonnay/org-beautify-theme")
+   (synopsis "Theme to make org mode look more beautiful")
+   (description "Adds padding between headings, increases the size of
+titles, strike through completed TODO headings, changes org blocks,
+changes org check boxes, and more.")
+   (license license:gpl3+)))