diff mbox series

[bug#54847,v2] gnu: Add python-hypy-utils.

Message ID DM5PR04MB3772EE66C530B75DC96D766199F59@DM5PR04MB3772.namprd04.prod.outlook.com
State Accepted
Headers show
Series [bug#54847,v2] gnu: Add python-hypy-utils. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wamm K. D April 20, 2022, 6:15 p.m. UTC
---
There's been new commits since I first sent this patch so just resending, after
pull.

 gnu/packages/python-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

Ludovic Courtès April 27, 2022, 9:17 p.m. UTC | #1
Hi,

"Wamm K. D" <jaft.r@outlook.com> skribis:

> ---
> There's been new commits since I first sent this patch so just resending, after
> pull.
>
>  gnu/packages/python-xyz.scm | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)

Added a commit log and applied it, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a5d311680..c242e1fa00 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,6 +119,7 @@ 
 ;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
 ;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
+;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29534,3 +29535,19 @@  (define-public python-sre-yield
 uses the parsed regular expression, so you get a much more accurate result
 than trying to just split strings.")
     (license license:asl2.0)))
+
+(define-public python-hypy-utils
+  (package
+    (name "python-hypy-utils")
+    (version "1.0.6")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "hypy_utils" version))
+              (sha256 (base32
+                       "05csk0x8ivavq88x457cq5hwjcdirfbkzj7bbg5qgnpnf2dxxhiw"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/hykilpikonna/HyPyUtils")
+    (synopsis "Python utility functions for HyDEV")
+    (description "This module provides Python utility functions for modifying
+and setting the color of terminal output, via HyDEV.")
+    (license license:expat)))