diff mbox series

[bug#52114,v2] * gnu/packages/xdisorg.scm (skippy-xd): New variable.

Message ID DM5PR04MB37724DA0A278290ECB0BD325990A9@DM5PR04MB3772.namprd04.prod.outlook.com
State New
Headers show
Series [bug#52114,v2] * gnu/packages/xdisorg.scm (skippy-xd): New variable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wamm K. D March 9, 2022, 10:48 p.m. UTC
---
Gah; I'm so sorry about the lapse in time, Nicolas. I completely missed that
there was any response. I tried it out and it runs pretty nicely, I'd say.
There's been quite a few changes and just applying the patch failed for me so
I'm just sending a new one, built after the lastest commits, in case this helps,
any. Thanks a ton!
 gnu/packages/xdisorg.scm | 59 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 6dc40f0910..b9e26f0511 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -52,6 +52,7 @@ 
 ;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;;
@@ -2973,6 +2974,64 @@  (define-public jumpapp
     (home-page "https://github.com/mkropat/jumpapp")
     (license license:expat)))
 
+(define-public skippy-xd
+  ;; XXX: Upstream made no release so far.  Using latest commit.
+  (let ((commit "397216ca67074c71314f5e9a6e3f1710ccabc29e")
+        (revision "1"))
+    (package
+      (name "skippy-xd")
+      ;; Version is extracted from Debian's "control" file.
+      (version (git-version "0.5" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/richardgv/skippy-xd")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0zcjacilmsv69rv85j6nfr6pxy8z36w1sjz0dbjg6s5m4kga1zl8"))))
+      (build-system  gnu-build-system)
+      (arguments
+       (list
+        #:tests? #f                     ;no tests
+        #:phases
+        #~(modify-phases %standard-phases
+            (delete 'configure)         ;no configure script
+            (add-after 'unpack 'set-version
+              ;; SKIPPYXD_VERSION is a git commit hash.  Display our own, more
+              ;; informative (?) version string instead.
+              (lambda _
+                (substitute* "Makefile"
+                  (("\\$\\{SKIPPYXD_VERSION\\}") #$version)))))
+        #:make-flags
+        ;; XXX: Setting both PREFIX and DESTDIR is needed to work around
+        ;; a Makefile problem when moving files to "%output/etc/xdg".
+        #~(list (string-append "PREFIX=/")
+                (string-append "DESTDIR=" #$output)
+                #$(string-append "CC=" (cc-for-target)))))
+      (native-inputs
+       (list pkg-config))
+      (inputs
+       (list giflib
+             libjpeg-turbo
+             libx11
+             libxcomposite
+             libxdamage
+             libxext
+             libxft
+             libxinerama))
+      (home-page "https://github.com/richardgv/skippy-xd/")
+      (synopsis "Full-screen Exposé-style standalone task switcher for X11")
+      (description "Skippy-XD is a program that provides Exposé-like features
+such as found on the MacOS X operating system.  It is a standalone application
+for providing a window picker with live previews (including live video) on
+Linux desktops that run an X server with compositing support.  Thus, it is not
+part of the window manager and the compositing is not being used all the
+time.")
+      (license license:gpl2+))))
+
 (define-public xkbset
   (package
     (name "xkbset")