diff mbox series

[bug#52238] gnu: megacmd: Add mega-sdk as dependency.

Message ID DM5PR04MB377212270DC40C9C37EFAFC699299@DM5PR04MB3772.namprd04.prod.outlook.com
State New
Headers show
Series [bug#52238] gnu: megacmd: Add mega-sdk as dependency. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wamm K. D Feb. 4, 2022, 12:34 a.m. UTC
* gnu/packages/sync.scm (megacmd): Use new package mega-sdk as dependency
rather than build mega-sdk via building recursively.
---
 gnu/packages/sync.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Liliana Marie Prikler Feb. 4, 2022, 6:18 p.m. UTC | #1
Am Donnerstag, dem 03.02.2022 um 18:34 -0600 schrieb Wamm K. D:
> * gnu/packages/sync.scm (megacmd): Use new package mega-sdk as
> dependency
> rather than build mega-sdk via building recursively.
> ---
>  gnu/packages/sync.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
> index 52003a7c9d..753b4e4d47 100644
> --- a/gnu/packages/sync.scm
> +++ b/gnu/packages/sync.scm
> @@ -281,8 +281,7 @@ (define-public megacmd
>          (method git-fetch)
>          (uri (git-reference
>                (url "https://github.com/meganz/MEGAcmd")
> -              (commit (string-append version "_Linux"))
> -              (recursive? #t)))
> +              (commit (string-append version "_Linux"))))
>          (sha256
>           (base32
>            "004j8m3xs6slx03g2g6wzr97myl2v3zc09wxnfar5c62a625pd53"))
> @@ -301,6 +300,7 @@ (define-public megacmd
>         ("curl" ,curl)
>         ("freeimage" ,freeimage)
>         ("gtest" ,googletest)
> +       ("mega-sdk" ,mega-sdk)
>         ("openssl" ,openssl)
>         ("pcre" ,pcre)
>         ("readline" ,readline)
Note that the hash didn't change, so you're still fetching the
recursive version.  In addition, the non-recursive version won't build
as mega-sdk is deeply bundled into megacmd.
Wamm K. D Feb. 5, 2022, 3:05 a.m. UTC | #2
Hmm; perhaps a past installed caused things to build last time I tried this. I see what you mean, now.
In that case, I'm not sure that I have enough experience or knowledge with make tools to be able to untangle things, I'm afraid.
    On Friday, February 4, 2022, 12:18:50 PM CST, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:  
 
 Am Donnerstag, dem 03.02.2022 um 18:34 -0600 schrieb Wamm K. D:
> * gnu/packages/sync.scm (megacmd): Use new package mega-sdk as
> dependency
> rather than build mega-sdk via building recursively.
> ---
>  gnu/packages/sync.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
> index 52003a7c9d..753b4e4d47 100644
> --- a/gnu/packages/sync.scm
> +++ b/gnu/packages/sync.scm
> @@ -281,8 +281,7 @@ (define-public megacmd
>          (method git-fetch)
>          (uri (git-reference
>                (url "https://github.com/meganz/MEGAcmd")
> -              (commit (string-append version "_Linux"))
> -              (recursive? #t)))
> +              (commit (string-append version "_Linux"))))
>          (sha256
>           (base32
>            "004j8m3xs6slx03g2g6wzr97myl2v3zc09wxnfar5c62a625pd53"))
> @@ -301,6 +300,7 @@ (define-public megacmd
>         ("curl" ,curl)
>         ("freeimage" ,freeimage)
>         ("gtest" ,googletest)
> +       ("mega-sdk" ,mega-sdk)
>         ("openssl" ,openssl)
>         ("pcre" ,pcre)
>         ("readline" ,readline)
Note that the hash didn't change, so you're still fetching the
recursive version.  In addition, the non-recursive version won't build
as mega-sdk is deeply bundled into megacmd.
Liliana Marie Prikler Feb. 5, 2022, 6:59 a.m. UTC | #3
Am Samstag, dem 05.02.2022 um 03:05 +0000 schrieb Jaft:
> Hmm; perhaps a past installed caused things to build last time I
> tried this. I see what you mean, now.
Not necessarily.  As I said, Guix already has substitutes for the
source, so it will fetch them regardless.

> In that case, I'm not sure that I have enough experience or knowledge
> with make tools to be able to untangle things, I'm afraid.
Fair enough, on the top of my head I'm not too sure how to untangle
this either.  However, note that mega-sdk appears pretty useless as a
standalone package, so I'd like to solve that issue before pushing it.

Cheers
Wamm K. D Feb. 13, 2022, 8:34 a.m. UTC | #4
> On Saturday, February 5, 2022, 12:59:47 AM CST, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote: 
>
>
>
>
>
> Am Samstag, dem 05.02.2022 um 03:05 +0000 schrieb Jaft:
> > In that case, I'm not sure that I have enough experience or knowledge
> > with make tools to be able to untangle things, I'm afraid.
> Fair enough, on the top of my head I'm not too sure how to untangle
> this either.  However, note that mega-sdk appears pretty useless as a
> standalone package, so I'd like to solve that issue before pushing it.

That's fair; I had been first trying to get it added as a package as I was trying to package up MEGAsync and, as you might imagine, this is a dependency of it. I've nearly got the MEGAsync package working but need to get icons working properly, still; if I'm able to get it, would it make sense to send a patch here and move forward with that package?
Liliana Marie Prikler Feb. 13, 2022, 8:42 a.m. UTC | #5
Am Sonntag, dem 13.02.2022 um 08:34 +0000 schrieb Jaft:
> > On Saturday, February 5, 2022, 12:59:47 AM CST, Liliana Marie
> > Prikler <liliana.prikler@gmail.com> wrote: 
> > Am Samstag, dem 05.02.2022 um 03:05 +0000 schrieb Jaft:
> > > In that case, I'm not sure that I have enough experience or
> > > knowledge with make tools to be able to untangle things, I'm
> > > afraid.
> > Fair enough, on the top of my head I'm not too sure how to untangle
> > this either.  However, note that mega-sdk appears pretty useless as
> > a standalone package, so I'd like to solve that issue before
> > pushing it.
> 
> That's fair; I had been first trying to get it added as a package as
> I was trying to package up MEGAsync and, as you might imagine, this
> is a dependency of it. I've nearly got the MEGAsync package working
> but need to get icons working properly, still; if I'm able to get it,
> would it make sense to send a patch here and move forward with that
> package?
Sure.  As long as there's a consumer to test that the package is
working as expected, everything ought to be fine.  I don't know which
road will be the easier one, however.
diff mbox series

Patch

diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 52003a7c9d..753b4e4d47 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -281,8 +281,7 @@  (define-public megacmd
         (method git-fetch)
         (uri (git-reference
               (url "https://github.com/meganz/MEGAcmd")
-              (commit (string-append version "_Linux"))
-              (recursive? #t)))
+              (commit (string-append version "_Linux"))))
         (sha256
          (base32
           "004j8m3xs6slx03g2g6wzr97myl2v3zc09wxnfar5c62a625pd53"))
@@ -301,6 +300,7 @@  (define-public megacmd
        ("curl" ,curl)
        ("freeimage" ,freeimage)
        ("gtest" ,googletest)
+       ("mega-sdk" ,mega-sdk)
        ("openssl" ,openssl)
        ("pcre" ,pcre)
        ("readline" ,readline)