diff mbox series

[bug#42524] gnu: Add azimuth.

Message ID DM5PR03MB3306672C8019C3585C31AF49AE770@DM5PR03MB3306.namprd03.prod.outlook.com
State Accepted
Headers show
Series [bug#42524] gnu: Add azimuth. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Hass, Trevor Stenten July 24, 2020, 11:37 p.m. UTC

Comments

Oleg Pykhalov July 25, 2020, 10:57 a.m. UTC | #1
Hi,

"Hass, Trevor Stenten" <thass@okstate.edu> writes:

> From 9b2c4fe57162b0288083998f03cabb8221c7d117 Mon Sep 17 00:00:00 2001
> From: Trevor Hass <thass@okstate.edu>
> Date: Fri, 24 Jul 2020 18:22:56 -0500
> Subject: [PATCH] * gnu/packages/games.scm (azimuth): New variable.

Should also put a “gnu: Add azimuth.” line in the Git message.

> ---
>  gnu/packages/games.scm | 38 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 38 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 213acc6b9f..128a78460c 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -52,6 +52,7 @@

[…]

Runs great,  ;-)

Pushed to master.

Thanks,
Oleg.
diff mbox series

Patch

From 9b2c4fe57162b0288083998f03cabb8221c7d117 Mon Sep 17 00:00:00 2001
From: Trevor Hass <thass@okstate.edu>
Date: Fri, 24 Jul 2020 18:22:56 -0500
Subject: [PATCH] * gnu/packages/games.scm (azimuth): New variable.

---
 gnu/packages/games.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 213acc6b9f..128a78460c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -52,6 +52,7 @@ 
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Trevor Hass <thass@okstate.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11667,3 +11668,40 @@  game.")  ;thanks to Debian for description
      "With PokerTH you can play the Texas holdem poker game, either against
 computer opponents or against real players online.")
     (license license:agpl3+)))
+
+(define-public azimuth
+  (package
+    (name "azimuth")
+    ;; Not marked as latest release, but it fixes a compiling issue
+    ;; and adds the install target.
+    (version "1.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mdsteele/azimuth")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1znfvpmqiixd977jv748glk5zc4cmhw5813zp81waj07r9b0828r"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:test-target "test"
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)            ; no configure script
+         ;; Build release version instead of debug version.
+         (add-after 'unpack 'set-release
+           (lambda _
+             (setenv "BUILDTYPE" "release") #t))
+         (add-after 'unpack 'fix-install ; set install directory
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "Makefile" (("/usr") (assoc-ref outputs "out"))) #t)))))
+    (inputs `(("sdl" ,sdl)))
+    (home-page "https://mdsteele.games/azimuth/")
+    (synopsis "Metroidvania game with vector graphics")
+    (description
+     "Pilot your ship inside a planet to find and rescue the colonists trapped
+inside the Zenith Colony.")
+    (license license:gpl3+)))
-- 
2.27.0