diff mbox series

[bug#61408] gnu: bees: Update to 0.9.1.

Message ID DM5PR03MB3163F7ED9C248B5C3CB2B1F1C5DE9@DM5PR03MB3163.namprd03.prod.outlook.com
State New
Headers show
Series [bug#61408] gnu: bees: Update to 0.9.1. | expand

Commit Message

Morgan Smith Feb. 10, 2023, 6:08 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/file-systems.scm (bees): Update to 0.9.1.
* gnu/local.mk: Remove bees-beesd-honor-destdir-on-installation.patch
* gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch: Delete
file
---

I looked at all the source files, looked at the changes since v0.8, and even
ran the new version successfully on my system.  I think I've been pretty
thorough on this patch

 gnu/local.mk                                  |  1 -
 gnu/packages/file-systems.scm                 | 13 +++---
 ...-beesd-honor-destdir-on-installation.patch | 40 -------------------
 3 files changed, 5 insertions(+), 49 deletions(-)
 delete mode 100644 gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index f1fed73987..83d6399efd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -940,7 +940,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/bsd-games-prevent-name-collisions.patch	\
   %D%/packages/patches/bsd-games-stdio.h.patch			\
   %D%/packages/patches/beancount-disable-googleapis-fonts.patch	\
-  %D%/packages/patches/bees-beesd-honor-destdir-on-installation.patch	\
   %D%/packages/patches/beignet-correct-file-names.patch		\
   %D%/packages/patches/bidiv-update-fribidi.patch		\
   %D%/packages/patches/binutils-2.37-file-descriptor-leak.patch	\
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 049ef04ea8..f0e022ba0d 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1809,7 +1809,7 @@  (define-public fuse-overlayfs
 (define-public bees
   (package
     (name "bees")
-    (version "0.8")
+    (version "0.9.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1826,14 +1826,9 @@  (define-public bees
                      (("city.o.*") ""))
                    (substitute* "src/bees-hash.cc"
                      (("#include .crucible/city.h.") "#include <city.h>"))))
-              (patches
-               (search-patches
-                ;; XXX: Cherry-picked from upstream, remove the patch when
-                ;; bumping version.
-                "bees-beesd-honor-destdir-on-installation.patch"))
               (sha256
                (base32
-                "1kxpz1p9k5ir385kpvmfjawki5vg22hlx768k7835w6n5z5a65y4"))))
+                "1h2a7p1ik27cykbnql5b36wfv4n2arw4289p2vvs0v471b0x3b1c"))))
     (build-system gnu-build-system)
     (arguments
      (list #:test-target "test"
@@ -1876,7 +1871,9 @@  (define-public bees
 for large btrfs filesystems.  It is an offline dedupe combined with an
 incremental data scan capability to minimize time data spends on disk from
 write to dedupe.")
-    (license license:gpl3+)))
+    (license (list license:gpl3+
+                   license:zlib      ; lib/crc64.cc
+                   license:gpl2))))  ; include/crucible/btrfs.h
 
 (define-public dwarfs
   (package
diff --git a/gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch b/gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch
deleted file mode 100644
index 93817f42cf..0000000000
--- a/gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch
+++ /dev/null
@@ -1,40 +0,0 @@ 
-From 66b00f8a972ebb4da68f7aa0d0656f43ce2a2c3a Mon Sep 17 00:00:00 2001
-From: Hilton Chain <hako@ultrarare.space>
-Date: Fri, 23 Dec 2022 11:04:46 +0800
-Subject: [PATCH] beesd: Honor DESTDIR on installation.
-
-Co-authored-by: Adam Faiz <adam.faiz@disroot.org>
-Signed-off-by: Hilton Chain <hako@ultrarare.space>
----
- Defines.mk       | 1 +
- scripts/beesd.in | 2 +-
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/Defines.mk b/Defines.mk
-index 9e8df40..e5394ba 100644
---- a/Defines.mk
-+++ b/Defines.mk
-@@ -2,6 +2,7 @@ MAKE += PREFIX=$(PREFIX) LIBEXEC_PREFIX=$(LIBEXEC_PREFIX) ETC_PREFIX=$(ETC_PREFI
-
- define TEMPLATE_COMPILER =
- sed $< >$@ \
-+		-e's#@DESTDIR@#$(DESTDIR)#' \
- 		-e's#@PREFIX@#$(PREFIX)#' \
- 		-e's#@ETC_PREFIX@#$(ETC_PREFIX)#' \
- 		-e's#@LIBEXEC_PREFIX@#$(LIBEXEC_PREFIX)#'
-diff --git a/scripts/beesd.in b/scripts/beesd.in
-index 174bb6c..35d04aa 100755
---- a/scripts/beesd.in
-+++ b/scripts/beesd.in
-@@ -15,7 +15,7 @@ readonly AL128K="$((128*1024))"
- readonly AL16M="$((16*1024*1024))"
- readonly CONFIG_DIR=@ETC_PREFIX@/bees/
-
--readonly bees_bin=$(realpath @LIBEXEC_PREFIX@/bees)
-+readonly bees_bin=$(realpath @DESTDIR@/@LIBEXEC_PREFIX@/bees)
-
- command -v "$bees_bin" &> /dev/null || ERRO "Missing 'bees' agent"
-
---
-2.38.1
-