diff mbox series

[bug#56964] gnu: Add emacs-buffer-env.

Message ID DM5PR03MB3163D2642001B57A37FD5E56C59F9@DM5PR03MB3163.namprd03.prod.outlook.com
State Accepted
Headers show
Series [bug#56964] gnu: Add emacs-buffer-env. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith Aug. 4, 2022, 12:37 a.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-buffer-env): New variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Nicolas Goaziou Aug. 25, 2022, 11:48 a.m. UTC | #1
Hello,

Morgan.J.Smith@outlook.com writes:

> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-buffer-env): New variable.

Applied with the following change. Thank you.

> +    (description "Create buffer-local environments using scripts similar to
> +direnv.  This allows Emacs to call the correct version of external programs
> +such as linters, compilers, and language servers on a per-project basis.")
> +    (license license:gpl3+)))

I sligthly changed the description so it would start with a complete sentence.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7a060783f8..a9c1869474 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29431,6 +29431,26 @@  (define-public emacs-boxquote
 example code.")
     (license license:gpl3+)))
 
+(define-public emacs-buffer-env
+  (package
+    (name "emacs-buffer-env")
+    (version "0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://elpa.gnu.org/packages/buffer-env-"
+                                  version ".tar"))
+              (sha256
+               (base32
+                "0y8ik87dqldhn6q631zp2ln9z5byqgm9icrvr4xrdx6g8mr9c56z"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-compat))
+    (home-page "https://github.com/astoff/buffer-env")
+    (synopsis "Create buffer-local process environments")
+    (description "Create buffer-local environments using scripts similar to
+direnv.  This allows Emacs to call the correct version of external programs
+such as linters, compilers, and language servers on a per-project basis.")
+    (license license:gpl3+)))
+
 (define-public emacs-buffer-move
   (package
     (name "emacs-buffer-move")