diff mbox series

[bug#58074] gnu: Add cyrus-sasl-xoauth2.

Message ID DM5PR03MB31637C2C7C30C6360865EEBBC5539@DM5PR03MB3163.namprd03.prod.outlook.com
State New
Headers show
Series [bug#58074] gnu: Add cyrus-sasl-xoauth2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith Sept. 25, 2022, 3:15 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/cyrus-sasl.scm (cyrus-sasl-xoauth2): New variable.
---
 gnu/packages/cyrus-sasl.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Ludovic Courtès Oct. 6, 2022, 8:47 p.m. UTC | #1
Hi,

Morgan.J.Smith@outlook.com skribis:

> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/cyrus-sasl.scm (cyrus-sasl-xoauth2): New variable.

LGTM, modulo two things:

> +    (native-search-paths
> +     (list (search-path-specification
> +            (variable "SASL_PATH")
> +            (files (list "lib/sasl2")))))

I believe this search path belongs in cyrus-sasl (see
<https://guix.gnu.org/manual/devel/en/html_node/Search-Paths.html>).

Could you provide a patch that does that?  However, due to the number of
dependents of cyrus-sasl, this change will have to go on ‘staging’.

> +    (home-page "https://github.com/moriyoshi/cyrus-sasl-xoauth2")
> +    (synopsis "XOAUTH2 plugin for Cyrus SASL")
> +    (description "Adds support for XOAUTH2 authentication to Cyrus SASL.  Can
> +be used with isync to fetch mail from servers that support it.")

Please write full sentences.

Thanks in advance,
Ludo’.
Zac Berkowitz March 15, 2024, 2:46 p.m. UTC | #2
Also using cyrus-sasl-xoauth2 on a local channel would like to have it part
of Guix proper.

Zac
diff mbox series

Patch

diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 2cd18f3e5e..5374effbcd 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,8 +27,10 @@  (define-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages kerberos)
   #:use-module (gnu packages tls)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu))
 
 (define-public cyrus-sasl
@@ -78,3 +81,34 @@  (define-public cyrus-sasl
    (license (license:non-copyleft "file://COPYING"
                                   "See COPYING in the distribution."))
    (home-page "https://cyrusimap.org/sasl/")))
+
+(define-public cyrus-sasl-xoauth2
+  (package
+    (name "cyrus-sasl-xoauth2")
+    (version "0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/moriyoshi/cyrus-sasl-xoauth2")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1py9f1mn5k5xihrk0lfrwr6723c22gjb7lmgya83ibvislm2x3wl"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:configure-flags #~(list (string-append "--with-cyrus-sasl="
+                                                    #$output)
+                                     "--disable-static")))
+
+    (inputs (list cyrus-sasl))
+    (native-inputs (list autoconf automake libtool))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "SASL_PATH")
+            (files (list "lib/sasl2")))))
+    (home-page "https://github.com/moriyoshi/cyrus-sasl-xoauth2")
+    (synopsis "XOAUTH2 plugin for Cyrus SASL")
+    (description "Adds support for XOAUTH2 authentication to Cyrus SASL.  Can
+be used with isync to fetch mail from servers that support it.")
+    (license license:expat)))