diff mbox series

[bug#62271] gnu: Add emacs-jit-spell.

Message ID DM5PR03MB31634D4D02439D6E07F63A74C5839@DM5PR03MB3163.namprd03.prod.outlook.com
State New
Headers show
Series [bug#62271] gnu: Add emacs-jit-spell. | expand

Commit Message

Morgan Smith March 19, 2023, 3:47 a.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-jit-spell): New variable.
---

This package only refers to aspell/ispell/whatever through variables defined in
Emacs proper so we don't have to care about patching any paths or anything.

 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou March 24, 2023, 9:16 a.m. UTC | #1
Hello,

Morgan.J.Smith@outlook.com writes:

> * gnu/packages/emacs-xyz.scm (emacs-jit-spell): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 05c326d423..fe3b73a2dc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9579,6 +9579,30 @@  (define-public emacs-jinja2-mode
 sgml/html integration, and indentation (working with sgml).")
     (license license:gpl3+)))
 
+(define-public emacs-jit-spell
+  (package
+    (name "emacs-jit-spell")
+    (version "0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://elpa.gnu.org/packages/jit-spell-"
+                                  version ".tar"))
+              (sha256
+               (base32
+                "10h2nbp6lap26arwifhzs119mkfj76fvjsix3iccjjvfdi88wdn9"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-compat))
+    (home-page "https://github.com/astoff/jit-spell")
+    (synopsis "Just-in-time spell checking")
+    (description
+     "This package highlights all misspelled words in a window, just like a
+word processor or web browser does.  This behavior is different from the
+built-in Flyspell package, which only checks words as the cursor moves over
+them.  Moreover, unlike Flyspell, jit-spell communicates with the
+spell-checking subprocess entirely asynchronously, which can lead to a
+noticeable performance improvement.")
+    (license license:gpl3+)))
+
 (define-public emacs-company-cabal
   ;; The latest version is 0.3.0, but no release has been provided after 0.2.1.
   (let ((commit "62112a7259e24bd6c08885629a185afe512b7d3d")