diff mbox series

[bug#57495,v2] gnu: Add steam-devices-udev-rules.

Message ID DM5PR03MB3163400722CA8BAC8BF75761C5789@DM5PR03MB3163.namprd03.prod.outlook.com
State Accepted
Headers show
Series [bug#57495,v2] gnu: Add steam-devices-udev-rules. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith Aug. 31, 2022, 4:44 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/games.scm (steam-devices-udev-rules): New variable.
---

I've incorporated both of your suggestions into the following patch


 gnu/packages/games.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

John Kehayias Sept. 9, 2022, 8:15 p.m. UTC | #1
On Wed, Aug 31, 2022 at 12:44 PM, Morgan.J.Smith@outlook.com wrote:

> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/games.scm (steam-devices-udev-rules): New variable.
> ---
>
> I've incorporated both of your suggestions into the following patch
>
>
[snip]

LGTM

I checked that it builds and the output looks correct (correct location, took a peek at the udev rules)
Mathieu Othacehe Sept. 11, 2022, 2:38 p.m. UTC | #2
Applied, thanks to all reviewers :)

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fe66343a4c..98e5389903 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12591,3 +12591,38 @@  (define-public freerct
 Should they go unwise, a theme park plunge into chaos with vandalizing guests
 and unsafe rides.  Which path will you take?")
     (license license:gpl2)))
+
+(define-public steam-devices-udev-rules
+  ;; Last release from 2019-04-10
+  (let ((commit "d87ef558408c5e7a1a793d738db4c9dc2cb5f8fa")
+        (revision "0"))
+    (package
+      (name "steam-devices-udev-rules")
+      (version (git-version "1.0.0.61" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/ValveSoftware/steam-devices")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1yqigraz9f19018ma5n2pbx7naadh9960lia3z8ayg7vz1fjdl54"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan '(("./" "lib/udev/rules.d"
+                           #:include-regexp ("rules$")))
+         #:phases (modify-phases %standard-phases
+                    (add-after 'unpack 'patch-paths
+                      (lambda* (#:key inputs #:allow-other-keys)
+                        (substitute* "60-steam-input.rules"
+                          (("/bin/sh")
+                           (search-input-file inputs "/bin/sh"))
+                          (("udevadm")
+                           (search-input-file inputs "/bin/udevadm"))))))))
+      (inputs (list eudev))
+      (home-page "https://github.com/ValveSoftware/steam-devices")
+      (synopsis "udev rules for game controllers and virtual reality devices")
+      (description
+       "Provides a set of udev rules for game controllers and virtual reality devices.")
+      (license license:expat))))