diff mbox series

[bug#61408,v2] gnu: bees: Update to 0.9.1.

Message ID DM5PR03MB31630468C686EA7FC31AE876C5DC9@DM5PR03MB3163.namprd03.prod.outlook.com
State New
Headers show
Series [bug#61408,v2] gnu: bees: Update to 0.9.1. | expand

Commit Message

Morgan Smith Feb. 12, 2023, 6:12 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/file-systems.scm (bees): Update to 0.9.1.
[arguments]: Add fixtest phase.
* gnu/local.mk: Remove bees-beesd-honor-destdir-on-installation.patch
* gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch: Delete
file
---

I have just discovered https://qa.guix.gnu.org and it is very cool.  It helped
me fix this patch :)

 gnu/local.mk                                  |  1 -
 gnu/packages/file-systems.scm                 | 22 +++++-----
 ...-beesd-honor-destdir-on-installation.patch | 40 -------------------
 3 files changed, 13 insertions(+), 50 deletions(-)
 delete mode 100644 gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch

Comments

Tobias Geerinckx-Rice Feb. 23, 2023, 10:57 p.m. UTC | #1
Hi Morgan,

I've pushed an updated & modified version of this patch as 
4f08551a83f3a9f5e22c70e51e488f38171e6937.  Thanks!

Morgan.J.Smith@outlook.com 写道:
> * gnu/packages/file-systems.scm (bees): Update to 0.9.1.
> [arguments]: Add fixtest phase.

Since you reported this failure upstream, 0.9.2 was released with 
your fix.  \o/

I used that instead.

> * gnu/local.mk: Remove 
> bees-beesd-honor-destdir-on-installation.patch
> * 
> gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch: 
> Delete
> file

I prefer writing this as

  * 
  gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch:
  Delete file.
  * gnu/local.mk (dist_patch_DATA): Remove it.

> +                   license:gpl2))))  ; include/crucible/btrfs.h

Nice!  Well spotted.

Now, any copyrightable change by BEES to this file would/will be 
GPL3+.  I didn't notice any in its commit log, though, so this 
point is academic.

I erred on the side of keeping this, and added an explicit comment 
that the combined work is GPL3+.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index cdb99813d0..669d431802 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -941,7 +941,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/bsd-games-prevent-name-collisions.patch	\
   %D%/packages/patches/bsd-games-stdio.h.patch			\
   %D%/packages/patches/beancount-disable-googleapis-fonts.patch	\
-  %D%/packages/patches/bees-beesd-honor-destdir-on-installation.patch	\
   %D%/packages/patches/beignet-correct-file-names.patch		\
   %D%/packages/patches/bidiv-update-fribidi.patch		\
   %D%/packages/patches/binutils-2.37-file-descriptor-leak.patch	\
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 471f943754..492ae23dd1 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1809,7 +1809,7 @@  (define-public fuse-overlayfs
 (define-public bees
   (package
     (name "bees")
-    (version "0.8")
+    (version "0.9.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1826,14 +1826,9 @@  (define-public bees
                      (("city.o.*") ""))
                    (substitute* "src/bees-hash.cc"
                      (("#include .crucible/city.h.") "#include <city.h>"))))
-              (patches
-               (search-patches
-                ;; XXX: Cherry-picked from upstream, remove the patch when
-                ;; bumping version.
-                "bees-beesd-honor-destdir-on-installation.patch"))
               (sha256
                (base32
-                "1kxpz1p9k5ir385kpvmfjawki5vg22hlx768k7835w6n5z5a65y4"))))
+                "1h2a7p1ik27cykbnql5b36wfv4n2arw4289p2vvs0v471b0x3b1c"))))
     (build-system gnu-build-system)
     (arguments
      (list #:test-target "test"
@@ -1845,6 +1840,12 @@  (define-public bees
            #:phases
            #~(modify-phases %standard-phases
                (delete 'configure)
+               (add-after 'unpack 'fixtest
+                 (lambda _
+                   ;; Reported upstream.  Check if fixed when updating.
+                   ;; Fixes build failure on i686 and armhf where size_t != uint64_t.
+                   (substitute* "test/seeker.cc"
+                     (("size_t target") "uint64_t target"))))
                (add-after 'unpack 'fixpath
                  (lambda* (#:key inputs #:allow-other-keys)
                    (substitute* "scripts/beesd.in"
@@ -1867,7 +1868,8 @@  (define-public bees
                       (search-input-file inputs (string-append "/bin/" command)))
 
                      (("btrfs sub")
-                      (string-append (search-input-file inputs "/bin/btrfs") " sub"))))))))
+                      (string-append (search-input-file inputs "/bin/btrfs")
+                                     " sub"))))))))
     (inputs (list btrfs-progs cityhash util-linux))
     (home-page "https://github.com/Zygo/bees")
     (synopsis "Best-Effort Extent-Same, a btrfs dedupe agent")
@@ -1876,7 +1878,9 @@  (define-public bees
 for large btrfs filesystems.  It is an offline dedupe combined with an
 incremental data scan capability to minimize time data spends on disk from
 write to dedupe.")
-    (license license:gpl3+)))
+    (license (list license:gpl3+
+                   license:zlib      ; lib/crc64.cc
+                   license:gpl2))))  ; include/crucible/btrfs.h
 
 (define-public dwarfs
   (package
diff --git a/gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch b/gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch
deleted file mode 100644
index 93817f42cf..0000000000
--- a/gnu/packages/patches/bees-beesd-honor-destdir-on-installation.patch
+++ /dev/null
@@ -1,40 +0,0 @@ 
-From 66b00f8a972ebb4da68f7aa0d0656f43ce2a2c3a Mon Sep 17 00:00:00 2001
-From: Hilton Chain <hako@ultrarare.space>
-Date: Fri, 23 Dec 2022 11:04:46 +0800
-Subject: [PATCH] beesd: Honor DESTDIR on installation.
-
-Co-authored-by: Adam Faiz <adam.faiz@disroot.org>
-Signed-off-by: Hilton Chain <hako@ultrarare.space>
----
- Defines.mk       | 1 +
- scripts/beesd.in | 2 +-
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/Defines.mk b/Defines.mk
-index 9e8df40..e5394ba 100644
---- a/Defines.mk
-+++ b/Defines.mk
-@@ -2,6 +2,7 @@ MAKE += PREFIX=$(PREFIX) LIBEXEC_PREFIX=$(LIBEXEC_PREFIX) ETC_PREFIX=$(ETC_PREFI
-
- define TEMPLATE_COMPILER =
- sed $< >$@ \
-+		-e's#@DESTDIR@#$(DESTDIR)#' \
- 		-e's#@PREFIX@#$(PREFIX)#' \
- 		-e's#@ETC_PREFIX@#$(ETC_PREFIX)#' \
- 		-e's#@LIBEXEC_PREFIX@#$(LIBEXEC_PREFIX)#'
-diff --git a/scripts/beesd.in b/scripts/beesd.in
-index 174bb6c..35d04aa 100755
---- a/scripts/beesd.in
-+++ b/scripts/beesd.in
-@@ -15,7 +15,7 @@ readonly AL128K="$((128*1024))"
- readonly AL16M="$((16*1024*1024))"
- readonly CONFIG_DIR=@ETC_PREFIX@/bees/
-
--readonly bees_bin=$(realpath @LIBEXEC_PREFIX@/bees)
-+readonly bees_bin=$(realpath @DESTDIR@/@LIBEXEC_PREFIX@/bees)
-
- command -v "$bees_bin" &> /dev/null || ERRO "Missing 'bees' agent"
-
---
-2.38.1
-