diff mbox series

[bug#66887] Subject: [PATCH 1/3] gnu: Add catatonit

Message ID DB9P190MB1985CD50B0ED6017C3F248E19EA7A@DB9P190MB1985.EURP190.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#66887] Subject: [PATCH 1/3] gnu: Add catatonit | expand

Commit Message

Wilke Schwiedop Nov. 1, 2023, 6:45 p.m. UTC
* gnu/packages/containers.scm (catatonit): New variable.
---
 gnu/packages/containers.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index a3aa9ac1db..e26b5acf21 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -309,6 +309,27 @@  (define-public cni-plugins
 
 ;; For podman to work, the user needs to run
 ;; `sudo mount -t cgroup2 none /sys/fs/cgroup`
+(define-public catatonit
+  (package
+    (name "catatonit")
+    (version "0.1.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/openSUSE/catatonit")
+             ; include fix for a build error that was merged shortly after 0.1.7
+             (commit "cf1fd8a1cc9a40a2c66019d9546891912419d747")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0ac3vfs5d1ka6q21wr4cya9ka8w4c3z1syzdq9sgrks7qnnkxm2h"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool))
+    (synopsis "Container init")
+    (description "A container init that is so simple it's effectively brain-dead.")
+    (home-page "https://github.com/openSUSE/catatonit")
+    (license license:gpl3)))
 
 (define-public podman
   (package