diff mbox series

[bug#41036] ruby: Update to 2.7.3

Message ID D8B3EvY7sfpXMoK0_e6aD-G3eLizVuwzuKqTb1SxvrSiuF3xePrYUXcys-fgxLYkh3TewK92xlsOukDxtz3Vz84xBImPV_QahqFLCNIcYjs=@protonmail.com
State Accepted
Headers show
Series [bug#41036] ruby: Update to 2.7.3 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

guix--- via Guix-patches via May 2, 2020, 11:34 p.m. UTC
Ruby 2.7.3 is the latest release. This patch updates the ruby package to point to 2.7.

Comments

Ludovic Courtès May 7, 2020, 7:47 a.m. UTC | #1
Hi,

Ryan Prior <rprior@protonmail.com> skribis:

> Ruby 2.7.3 is the latest release. This patch updates the ruby package to point to 2.7.

‘guix refresh -l ruby@2.5’ says there are 4K packages depending on it
(which I didn’t expect).  So this change should probably go to the next
‘core-updates’ according to our guidelines (info "(guix) Submitting
Patches").

Did you have a chance to test the impact of this change on Ruby
packages?  Perhaps you should ping other people who last upgraded Ruby.

Thanks,
Ludo’.
guix--- via Guix-patches via May 7, 2020, 7:27 p.m. UTC | #2
Hi there! I'm Ryan Prior, a rubyist and Guix maintainer. I'm writing you
because I'd like your feedback on my patches to add Ruby 2.7.3 to Guix
and eventually to make that the default version of Ruby. I got your
email address from the Ruby package in Guix master.

You can find my version of the Ruby package here:
https://github.com/ryanprior/guix-packages#ruby

Discussion is in the Guix issue tracker here:
https://issues.guix.gnu.org/issue/41036

Thank you for contributing to Ruby and Guix, I appreciate your time!


Ludovic Courtès (cc'd) <ludo@gnu.org> writes:

> ‘guix refresh -l ruby@2.5’ says there are 4K packages depending on it
> (which I didn’t expect).  So this change should probably go to the next
> ‘core-updates’ according to our guidelines (info "(guix) Submitting
> Patches").

I think it's a high priority to get 2.7 into Guix so people can start
testing it and building off of it, but fine to hold off
making it the default until the next core-update cycle.

> Did you have a chance to test the impact of this change on Ruby
> packages?  Perhaps you should ping other people who last upgraded
> Ruby.

I've tried a few core things like irb and bundler but have yet to
undertake a more serious testing plan.

Thank you for the suggestion Ludo!


Warmly,
Ryan Prior
Diego Nicola Barbato May 12, 2020, 8:10 a.m. UTC | #3
Hey Ryan,

Ryan Prior <rprior@protonmail.com> writes:

> Hi there! I'm Ryan Prior, a rubyist and Guix maintainer. I'm writing you
> because I'd like your feedback on my patches to add Ruby 2.7.3 to Guix
> and eventually to make that the default version of Ruby. I got your
> email address from the Ruby package in Guix master.

The only reason for my copyright line in gnu/packages/ruby.scm is that I
added the package ruby-wayback-machine-downloader [0] for which I used
the importer.  I know almost nothing about Ruby.

You might get more helpful feedback from the people who have contributed
to the Ruby package itself [1].

[...]

HTH,

Diego

[0]: https://git.savannah.gnu.org/cgit/guix.git/log/gnu/packages/ruby.scm?qt=author&q=barbato
[1]: https://git.savannah.gnu.org/cgit/guix.git/log/?qt=grep&q=gnu%3A+ruby%3A
Thompson, David May 12, 2020, 12:47 p.m. UTC | #4
On Sat, May 2, 2020 at 7:35 PM Ryan Prior via Guix-patches via
<guix-patches@gnu.org> wrote:
>
> Ruby 2.7.3 is the latest release. This patch updates the ruby package to point to 2.7.

According to the Ruby releases page the latest release is 2.7.1, not
2.7.3. Am I missing something?

https://www.ruby-lang.org/en/downloads/releases/

- Dave
guix--- via Guix-patches via May 12, 2020, 5:55 p.m. UTC | #5
Thompson, David <dthompson2@worcester.edu> writes:

> On Sat, May 2, 2020 at 7:35 PM Ryan Prior via Guix-patches via
> <guix-patches@gnu.org> wrote:
>>
>> Ruby 2.7.3 is the latest release. This patch updates the ruby package to point to 2.7.
>
> According to the Ruby releases page the latest release is 2.7.1, not
> 2.7.3. Am I missing something?

Hi David, I think I got confused when writing my email to debbugs. The
package says 2.7.1, which is correct, and all references in email
correspondence and patch titles to 2.7.3 should have been to 2.7.1.

Thank you for the correction!

Ryan
diff mbox series

Patch

From 0f61f3897a69e8c1cd46a10dc710028d6de03962 Mon Sep 17 00:00:00 2001
From: Ryan Prior <rprior@protonmail.com>
Date: Sat, 2 May 2020 18:22:31 -0500
Subject: [PATCH] gnu: ruby: Update to 2.7.3.

---
 gnu/packages/ruby.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f9e687e775..455469b03c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -74,7 +74,7 @@ 
   #:use-module (guix build-system ruby)
   #:use-module ((srfi srfi-1) #:select (alist-delete)))
 
-(define-public ruby
+(define-public ruby-2.5
   (package
     (name "ruby")
     (version "2.5.3")
@@ -130,7 +130,7 @@  a focus on simplicity and productivity.")
 
 (define-public ruby-2.7
   (package
-    (inherit ruby)
+    (inherit ruby-2.5)
     (version "2.7.1")
     (source
      (origin
@@ -170,7 +170,7 @@  a focus on simplicity and productivity.")
     (native-inputs
      `(("autoconf" ,autoconf)))))
 
-(define-public ruby-2.5 ruby)
+(define-public ruby ruby-2.7)
 
 (define-public ruby-2.4
   (package
-- 
2.17.1