diff mbox series

[bug#49702] gnu: Add swaylock-effects

Message ID CwBL6-F6YMX2ra9OLnCpVc0Ut5imO4U3CliYpqHflu7murpjD88BrLqx8Zlknyux3FwttwXK1t2r8wSaP9FqRsbiZaMfJBfX6xe45a7PcYA=@protonmail.com
State Accepted
Headers show
Series [bug#49702] gnu: Add swaylock-effects | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 23, 2021, 3:06 a.m. UTC
---
--
2.31.1

Comments

phodina Sept. 18, 2021, 8:04 a.m. UTC | #1
Hi!

Is there anything to be fixed in order to upstream this patch?

Sent with [ProtonMail](https://protonmail.com/) Secure Email.
Liliana Marie Prikler Sept. 18, 2021, 11:03 a.m. UTC | #2
Hi,

Am Freitag, den 23.07.2021, 03:06 +0000 schrieb phodina:
> ---
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 920a7cbb3e..b214e2a31c 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -45,6 +45,7 @@
>  ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
>  ;;; Copyright © 2021 qblade <qblade@protonmail.com>
>  ;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
> +;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -82,6 +83,7 @@
>    #:use-module (gnu packages bison)
>    #:use-module (gnu packages build-tools) ;for meson-0.55
>    #:use-module (gnu packages calendar)
> +  #:use-module (gnu packages commencement) ; for gcc>9
>    #:use-module (gnu packages datastructures)
>    #:use-module (gnu packages docbook)
>    #:use-module (gnu packages documentation)
> @@ -1578,6 +1580,29 @@ modules for building a Wayland compositor.")
>      (description "Swaylock is a screen locking utility for Wayland
> compositors.")
>      (license license:expat))) ; MIT license
> 
> +(define-public swaylock-effects
> +(package (inherit swaylock)
> +  (name "swaylock-effects")
> +  ;; Upstream v1.6-3 released on 16/11/2020
> +  (version "5cb9579faaf5662b111f5722311b701eff1c1d00")
> +  (source (origin
> +            (method git-fetch)
> +            (uri (git-reference
> +                  (url "https://github.com/mortie/swaylock-effects")
> +                  (commit version)))
> +            (sha256
> +             (base32
> +              "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"
> ))))
> +  ; Requires gcc>=9 see the issue here
> +  ; https://github.com/mortie/swaylock-effects/issues/26
> +  (native-inputs `(("gcc-toolchain", gcc-toolchain-9)
> +                   ,@(package-native-inputs swaylock)))
We don't typically use gcc-toolchain as package input, but rather gcc
itself.  gcc-toolchain exists so that users can spawn an environment in
which gcc just works™.
> +  (synopsis (string-append (package-synopsis swaylock) " with fancy
> effects"))
Synopsis should be a simple string.
> +  (description "Swaylock-effects is a fork of swaylock which adds
> built-in
> +screenshots and image manipulation effects like blurring. It's
> inspired by
> +i3lock-color, although the feature sets aren't perfectly
> overlapping.")
It is preferable to describe software in its own terms rather than
other software.  What about "Swaylock-effects is a fork of swaylock
with additional features, such as the ability to take a screenshot as
the background image, display a clock or apply image manipulation
techniques to the background image."?
> +  (home-page "https://github.com/mortie/swaylock-effects")))
> +
>  (define-public swaybg
>    (package
>      (name "swaybg")
> --
> 2.31.1
>
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 920a7cbb3e..b214e2a31c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -45,6 +45,7 @@ 
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -82,6 +83,7 @@ 
   #:use-module (gnu packages bison)
   #:use-module (gnu packages build-tools) ;for meson-0.55
   #:use-module (gnu packages calendar)
+  #:use-module (gnu packages commencement) ; for gcc>9
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
@@ -1578,6 +1580,29 @@  modules for building a Wayland compositor.")
     (description "Swaylock is a screen locking utility for Wayland compositors.")
     (license license:expat))) ; MIT license

+(define-public swaylock-effects
+(package (inherit swaylock)
+  (name "swaylock-effects")
+  ;; Upstream v1.6-3 released on 16/11/2020
+  (version "5cb9579faaf5662b111f5722311b701eff1c1d00")
+  (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/mortie/swaylock-effects")
+                  (commit version)))
+            (sha256
+             (base32
+              "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
+  ; Requires gcc>=9 see the issue here
+  ; https://github.com/mortie/swaylock-effects/issues/26
+  (native-inputs `(("gcc-toolchain", gcc-toolchain-9)
+                   ,@(package-native-inputs swaylock)))
+  (synopsis (string-append (package-synopsis swaylock) " with fancy effects"))
+  (description "Swaylock-effects is a fork of swaylock which adds built-in
+screenshots and image manipulation effects like blurring. It's inspired by
+i3lock-color, although the feature sets aren't perfectly overlapping.")
+  (home-page "https://github.com/mortie/swaylock-effects")))
+
 (define-public swaybg
   (package
     (name "swaybg")