diff mbox series

[bug#61443] gnu: Remove and deprecate tidy for tidy-html

Message ID CY4PR03MB31599720B6392CE31A7FAA48C5DC9@CY4PR03MB3159.namprd03.prod.outlook.com
State New
Headers show
Series [bug#61443] gnu: Remove and deprecate tidy for tidy-html | expand

Commit Message

Morgan Smith Feb. 12, 2023, 3:44 a.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/web.scm (tidy): Change to deprecated alias for tidy-html
* gnu/packages/pumpio.scm (pumpa): Use tidy-html instead of tidy and correct
header name.
* gnu/packages/markup.scm (hoedown):
* gnu/packages/photo.scm (enblend-enfuse):
* gnu/packages/php.scm (php):
* gnu/packages/python-xyz.scm (python-pytidylib):
Use tidy-html instead of tidy.
---
 gnu/packages/markup.scm     |  2 +-
 gnu/packages/photo.scm      |  2 +-
 gnu/packages/php.scm        |  2 +-
 gnu/packages/pumpio.scm     |  4 +++-
 gnu/packages/python-xyz.scm |  2 +-
 gnu/packages/web.scm        | 37 +++----------------------------------
 6 files changed, 10 insertions(+), 39 deletions(-)

Comments

Ludovic Courtès March 4, 2023, 4:45 p.m. UTC | #1
Hi,

Morgan.J.Smith@outlook.com skribis:

> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/web.scm (tidy): Change to deprecated alias for tidy-html
> * gnu/packages/pumpio.scm (pumpa): Use tidy-html instead of tidy and correct
> header name.
> * gnu/packages/markup.scm (hoedown):
> * gnu/packages/photo.scm (enblend-enfuse):
> * gnu/packages/php.scm (php):
> * gnu/packages/python-xyz.scm (python-pytidylib):
> Use tidy-html instead of tidy.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 35dd6d257b..9162b008e0 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -73,7 +73,7 @@  (define-public hoedown
        #:test-target "test"))
     (native-inputs
      `(("python" ,python-2)
-       ("tidy" ,tidy)))
+       ("tidy" ,tidy-html)))
     (synopsis "Markdown processing library")
     (description "Hoedown is a standards compliant, fast, secure markdown
 processing library written in C.")
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index d658b3d3e7..d66daf42a6 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -383,7 +383,7 @@  (define-public enblend-enfuse
            imagemagick
            libxml2
            texlive-tiny
-           tidy
+           tidy-html
            transfig))
     (inputs
      (list boost
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index e0cd47b846..974ccf8039 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -410,7 +410,7 @@  (define-public php
        ("postgresql" ,postgresql)
        ("readline" ,readline)
        ("sqlite" ,sqlite)
-       ("tidy" ,tidy)
+       ("tidy" ,tidy-html)
        ("zlib" ,zlib)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
diff --git a/gnu/packages/pumpio.scm b/gnu/packages/pumpio.scm
index 2f4dd359d1..5fb6e338e8 100644
--- a/gnu/packages/pumpio.scm
+++ b/gnu/packages/pumpio.scm
@@ -47,6 +47,8 @@  (define-public pumpa
        (modify-phases %standard-phases
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
+             (substitute* "src/util.cpp"
+               (("buffio\\.h") "tidybuffio.h"))
              ;; Fix dependency tests.
              (substitute* "pumpa.pro"
                (("/usr/include/tidy\\.h")
@@ -59,7 +61,7 @@  (define-public pumpa
                (invoke "qmake" prefix))
              #t)))))
     (inputs
-     (list aspell qtbase-5 tidy))
+     (list aspell qtbase-5 tidy-html))
     (synopsis "Qt-based pump.io client")
     (description "Pumpa is a simple pump.io client written in C++ and Qt.")
     (home-page "https://pumpa.branchable.com/")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 445f5a787d..9b16fc85be 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27161,7 +27161,7 @@  (define-public python-pytidylib
                  (("ctypes\\.util\\.find_library\\('tidy'\\)")
                   (format #f "'~a'" libtidy)))
                #t))))))
-    (inputs (list tidy))
+    (inputs (list tidy-html))
     (home-page "https://github.com/countergram/pytidylib")
     (synopsis "Python wrapper for HTML Tidy library")
     (description
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7e49f798ea..43fef91110 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1718,40 +1718,6 @@  (define-public libpsl
 UTS#46.")
     (license license:x11)))
 
-(define-public tidy
-  (package
-    (name "tidy")
-    (version "20091223")
-    (source (origin
-              (method cvs-fetch)
-              (uri (cvs-reference
-                    (root-directory
-                     ":pserver:anonymous@tidy.cvs.sourceforge.net:/cvsroot/tidy")
-                    (module "tidy")
-                    (revision "2009-12-23")))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "14dsnmirjcrvwsffqp3as70qr6bbfaig2fv3zvs5g7005jrsbvpb"))
-              (patches (search-patches "tidy-CVE-2015-5522+5523.patch"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'bootstrap
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      ;; configure.in and Makefile.am aren't in the root of the
-                      ;; source tree.
-                      (copy-recursively "build/gnuauto" ".")
-                      (setenv "AUTOMAKE" "automake --foreign")
-                      (invoke "autoreconf" "-vfi"))))))
-    (native-inputs
-     (list automake autoconf libtool))
-    (synopsis "HTML validator and tidier")
-    (description "HTML Tidy is a command-line tool and C library that can be
-used to validate and fix HTML data.")
-    (home-page "http://tidy.sourceforge.net/")
-    (license (license:x11-style "file:///include/tidy.h"))))
-
 (define-public esbuild
   (package
     (name "esbuild")
@@ -6204,6 +6170,9 @@  (define-public tidy-html
 functions of Tidy.")
     (license license:bsd-3)))
 
+(define-public tidy
+  (deprecated-package "tidy" tidy-html))
+
 (define-public hiawatha
   (package
     (name "hiawatha")