diff mbox series

[bug#49517] gnu: txr: Build documentation and update to 265.

Message ID CWYO-z9r2mu9y0WLMjXvUW4eG15F1gWB_fxOcHt9H7qS_LDeJMBL7XjpLYFjq1IjEdrdDbPezgLxkmoBNR_WHvsExCTGt5fBajbScQSj2s0=@apatience.com
State Accepted
Headers show
Series [bug#49517] gnu: txr: Build documentation and update to 265. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience July 12, 2021, 1:01 a.m. UTC
I've managed to fix one of the failing tests
and narrowed down the problem of the others.
(Only the second patch is different, but I've
attached both for your convenience.)

Best regards,
Paul
diff mbox series

Patch

From 9b9649013442b856d6b5d73e7c8a707d96399306 Mon Sep 17 00:00:00 2001
From: "Paul A. Patience" <paul@apatience.com>
Date: Sun, 11 Jul 2021 20:56:41 -0400
Subject: [PATCH 2/2] gnu: txr: Update to 265.

* gnu/packages/lisp.scm (txr)[version]: Update to 265.
[arguments]<#:phases>{disable-failing-tests}: New phase.
---
 gnu/packages/lisp.scm | 21 ++++++++++++++++++---
 1 file changed, 18 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 8f3be7dafe..37908f9ed3 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -906,7 +906,7 @@  the HTML documentation of TXR.")
 (define-public txr
   (package
     (name "txr")
-    (version "263")
+    (version "265")
     (source
      (origin
        (method git-fetch)
@@ -915,7 +915,7 @@  the HTML documentation of TXR.")
              (commit (string-append "txr-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "14zaziymnbr2ld79x4h7sf88bzzzj82w3xpavmcx7mhwannb2swh"))))
+        (base32 "0v39323rblhl3gr03midxkx9njzzvs0scm3kmfpw5s0n5jd6drr6"))))
     (build-system gnu-build-system)
     (native-inputs
      ;; Required to build the documentation.
@@ -938,7 +938,7 @@  the HTML documentation of TXR.")
                ;; stdlib/doc-syms.tl, which is anyway kept up to date with
                ;; each release (and is already compiled to stdlib/doc-syms.tlo
                ;; when genman.txr is run).
-               (("^@\\(output \"share/txr/stdlib/doc-syms\\.tl\"\\).*" line)
+               (("^@\\(output \"stdlib/doc-syms\\.tl\"\\).*" line)
                 (string-append "@(do (exit))\n" line)))
              #t))
          (add-after 'unpack 'fix-tests
@@ -946,6 +946,21 @@  the HTML documentation of TXR.")
              (substitute* (list "tests/017/realpath.tl"
                                 "tests/017/realpath.expected")
                (("/usr/bin") "/"))
+             (substitute* "tests/018/path-test.tl"
+               (("/bin") (dirname (which "sh"))))
+             #t))
+         (add-after 'unpack 'disable-failing-tests
+           (lambda _
+             (for-each delete-file
+                       ;; These tests fail because their calls to some
+                       ;; external commands fail.
+                       ;; (They pass when run manually in the directory
+                       ;; left by --keep-failed.)
+                       (map (lambda (f) (string-append "tests/" f))
+                            '("002/query-1.txr" ; Calls "ls".
+                              "010/json.tl"     ; Calls "cat".
+                              "018/process.tl"  ; Calls "echo".
+                              )))
              #t))
          (replace 'configure
            ;; ./configure is a hand-written script that can't handle standard
-- 
2.32.0