diff mbox series

[bug#66193] gnu: Add keyd

Message ID CVSWXT9ZHO24.3LDYDRIMBKSS7@fedora
State New
Headers show
Series [bug#66193] gnu: Add keyd | expand

Commit Message

ShinyZero0 Sept. 26, 2023, 2:21 p.m. UTC
From 4926a18454135e97832e2d183893f01a2f42a06c Mon Sep 17 00:00:00 2001
From: "zero@fedora" <shinyzero0@tilde.club>
Date: Mon, 25 Sep 2023 19:39:00 +0300
Subject: [PATCH] gnu: Add keyd

* gnu/packages/keyd.scm: New file.
* gnu/local.mk: Add it.
---
 gnu/local.mk          |  1 +
 gnu/packages/keyd.scm | 60 +++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 61 insertions(+)
 create mode 100644 gnu/packages/keyd.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index bfa816d717..f0745fed65 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -690,6 +690,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/services/guix.scm			\
   %D%/services/hurd.scm				\
   %D%/services/kerberos.scm			\
+  %D%/services/keyd.scm			\
   %D%/services/ldap.scm		      		\
   %D%/services/lightdm.scm      		\
   %D%/services/linux.scm			\
diff --git a/gnu/packages/keyd.scm b/gnu/packages/keyd.scm
new file mode 100644
index 0000000000..666b931650
--- /dev/null
+++ b/gnu/packages/keyd.scm
@@ -0,0 +1,60 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Paul <shinyzero0@tilde.club>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages keyd)
+  #:use-module (gnu packages linux)
+  #:use-module (guix packages)
+  #:use-module (guix gexp)
+  #:use-module (guix utils)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build-system gnu))
+
+(define-public keyd
+  (package
+    (name "keyd")
+    (version "2.4.3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/rvaiya/keyd")
+               (commit (string-append "v" version))))
+        (sha256
+          (base32
+            "1awdp863amq95y990fi4wj389ssv3ip2daqz2ph23lsahwa6f5in"))))
+    (arguments
+      (list #:tests? #f ; tests require root
+            #:make-flags
+            #~(list (string-append "CC=" #$(cc-for-target))
+                    "PREFIX="
+                    (string-append "DESTDIR=" #$output))
+            #:phases
+            '(modify-phases
+               %standard-phases
+               (delete 'configure)))) ; no autoconf
+    (build-system gnu-build-system)
+    (inputs (list linux-libre-headers))
+    (synopsis "A key remapping daemon for linux.")
+    (description
+      "Keyd is a keyboard remapping utility with intuitive ini
+      config file format. Keyd has several features, many of
+      which are traditionally only found in custom keyboard firmware
+      like QMK")
+    (home-page "https://github.com/rvaiya/keyd")
+    (license license:expat)))