diff mbox series

[bug#65197] add offpunk

Message ID CUOPJROOM6ZF.35KPDF9MJI7RB@Void
State New
Headers show
Series [bug#65197] add offpunk | expand

Commit Message

ShinyZero0 Aug. 10, 2023, 8:06 a.m. UTC
From 55885770d70ec38e190783c64322144d00495075 Mon Sep 17 00:00:00 2001
From: "zero@void" <shinyzero0@gmail.com>
Date: Thu, 10 Aug 2023 11:03:09 +0300
Subject: [PATCH] add offpunk

---
 gnu/packages/web-browsers.scm | 49 +++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)

Comments

Maxim Cournoyer Sept. 6, 2023, 5 a.m. UTC | #1
Hi,

This series look good for the most part.  It's just missing GNU
ChangeLog style commits message.  You can check other commits or read
'info (standards) ChangeLog' from the 'standards' package to get
familiar with it.

Could you send a v2 with the changelog added?
ShinyZero0 Sept. 18, 2023, 4:18 p.m. UTC | #2
Hi, do you mean it should have the capital "A"? I can't see any more
differences to another commit messages. Or maybe i'm looking at the
wrong place?
First time using email for patches :sweat:
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index c7143e3..e1b8fdd 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -43,6 +43,7 @@  (define-module (gnu packages web-browsers)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix download)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
@@ -61,6 +62,7 @@  (define-module (gnu packages web-browsers)
   #:use-module (gnu packages fltk)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages fonts)
+  #:use-module (gnu packages file)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages fribidi)
   #:use-module (gnu packages gcc)
@@ -71,7 +73,9 @@  (define-module (gnu packages web-browsers)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages image-viewers)
   #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages less)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libidn)
   #:use-module (gnu packages libunistring)
@@ -547,6 +551,51 @@  (define-public qutebrowser
 GUI.  It is based on PyQt5 and QtWebEngine.")
     (license license:gpl3+)))
 
+(define-public offpunk
+  (package
+    (name "offpunk")
+    (version "1.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~lioploum/offpunk")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "0r8j01s3hdn3iq4ld6pj3v0h4hpakvkc4h55jzz7jr6az4y8lcgs"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (delete 'check)
+                        (add-before 'wrap 'wrap-path
+                          (lambda* (#:key inputs outputs #:allow-other-keys)
+                            (wrap-program (string-append #$output
+                                                         "/bin/offpunk")
+                              `("PATH" ":" prefix
+                                (,(string-append #$(this-package-input "less")
+                                                 "/bin") ,(string-append #$(this-package-input
+                                                                            "file")
+                                                           "/bin")
+                                 ,(string-append #$(this-package-input
+                                                    "xdg-utils") "/bin")))))))))
+    (inputs (list python-cryptography
+                  python-requests
+                  python-feedparser
+                  python-beautifulsoup4
+                  python-readability-lxml
+                  python-flit
+                  xdg-utils
+                  file
+                  less))
+    (synopsis
+     "Command-line browser/feed reader for Gemini, Gopher, Spartan and Web")
+    (description
+     "The goal of Offpunk is to be able to synchronise your content once
+     (a day, a week, a month) and then browse/organise it while staying
+     disconnected")
+    (home-page "https://git.sr.ht/~lioploum/offpunk")
+    (license license:bsd-2)))
+
 (define-public vimb
   (package
     (name "vimb")