diff mbox series

[bug#51919] gnu: Add eg25-manager.

Message ID CIcGC1ikngvlNZweI3fgU8RBWz5nvx9Fc2glMtsSK3GNEzu8Je1F_fDCMf9tef3Lc9qe9KZimo02abNLKlsPkndNnrpJSkHsAqhc5DvVbW8=@protonmail.com
State Accepted
Headers show
Series [bug#51919] gnu: Add eg25-manager. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 17, 2021, 11:23 a.m. UTC
Hi,

this package adds support for modem-manager on Pinephone.

* gnu/packages/firmware.scm (eg25-manager): New variable.

--
2.33.0
diff mbox series

Patch

diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index aefc0a8b69..393e8ed431 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30,18 +31,24 @@  (define-module (gnu packages firmware)
   #:use-module (guix utils)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system meson)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages assembly)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages cmake)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages cross-base)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages gcc)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
+  #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages perl)
-  #:use-module (gnu packages python))
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages pkg-config))

 (define-public ath9k-htc-firmware
   (package
@@ -190,6 +197,32 @@  (define-public openfwwf-firmware
 by the b43-open driver of Linux-libre.")
     (license license:gpl2)))

+(define-public eg25-manager
+  (package
+    (name "eg25-manager")
+    (version "0.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/mobian1/devices/eg25-manager")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1h4c4ndcnh88jn65h1kycxkjrydwwwh3irkxvpaxb6ry4wpc45r0"))))
+    (build-system meson-build-system)
+    (native-inputs `(("curl" ,curl)
+                     ("glib" ,glib "bin")
+                     ("pkg-config" ,pkg-config)))
+    (inputs `(("libgpiod" ,libgpiod)
+              ("libgudev" ,libgudev)
+              ("libusb" ,libusb)))
+    (synopsis "Manager daemon for the Quectel EG25 mobile broadband modem")
+    (description "This package provides a manager daemon for the Quectel EG25
+        mobile broadband modem found e.g. on PinePhone.")
+    (home-page "https://gitlab.com/mobian1/devices/eg25-manager")
+    (license license:gpl3+)))
+
 (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
   (package
     (name name)