[bug#76594,v2,4/5] gnu: quilt: Don't install emacs package.

Message ID CH3PR84MB3424C798008EF5229A5A9282C5B02@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
State New
Headers
Series [bug#76594,v2,1/5] gnu: quilt: Respect #:tests? key in check phase. |

Commit Message

Morgan Smith April 13, 2025, 2:57 p.m. UTC
  * gnu/packages/patchutils.scm (quilt): Don't install quilt.el.  This is to be
moved to it's own guix package 'emacs-quilt'.

Change-Id: I4d70ad1c137a377f71cd9d3f1b69f5ed95e4debd
---
 gnu/packages/patchutils.scm | 5 +++++
 1 file changed, 5 insertions(+)
  

Comments

Liliana Marie Prikler April 13, 2025, 3:42 p.m. UTC | #1
Am Sonntag, dem 13.04.2025 um 10:57 -0400 schrieb Morgan Smith:
> * gnu/packages/patchutils.scm (quilt): Don't install quilt.el.  This
> is to be moved to it's own guix package 'emacs-quilt'.
> 
> Change-Id: I4d70ad1c137a377f71cd9d3f1b69f5ed95e4debd
> ---
What is the purpose of this and 5/5?  If it's the native compilation,
you could copy over the relevant phases from emacs-build-system.  There
are some packages that do that.


Cheers
  

Patch

diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 41a2daa36a..319b0e1284 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -189,6 +189,11 @@  (define-public quilt
      (list
       #:phases
       #~(modify-phases %standard-phases
+          (add-after 'unpack 'no-emacs
+           ;; Installed in emacs-quilt package
+           (lambda _
+             (substitute* "Makefile.in"
+               ((".*lib/quilt.el.*") ""))))
           (delete 'check)
           (add-after 'install 'wrap-script
             ;; quilt's configure checks for the absolute path to the utilities it