[bug#77611,v2] gnu: Remove duplicated package show-me-the-key.
Commit Message
This package is a duplicate of "showmethekey". Upstream seems to prefer
naming the package without hyphens in the name.
* gnu/packages/xdisorg.scm (show-me-the-key): Delete variable.
* gnu/packages/video.scm (show-me-the-key): Add as a deprecated alias for
showmethekey.
Change-Id: I21daae0826b6fbc5adf6d10a8497099875ae09f1
---
gnu/packages/video.scm | 9 +++++++++
gnu/packages/xdisorg.scm | 31 -------------------------------
2 files changed, 9 insertions(+), 31 deletions(-)
base-commit: f0c0769189d11debf7b237a02695c44c9773d52a
Comments
Morgan Smith <Morgan.J.Smith@outlook.com> skribis:
> This package is a duplicate of "showmethekey". Upstream seems to prefer
> naming the package without hyphens in the name.
>
> * gnu/packages/xdisorg.scm (show-me-the-key): Delete variable.
> * gnu/packages/video.scm (show-me-the-key): Add as a deprecated alias for
> showmethekey.
>
> Change-Id: I21daae0826b6fbc5adf6d10a8497099875ae09f1
Applied, thanks!
@@ -6941,3 +6941,12 @@ (define-public showmethekey
Users in group ``wheel'' can skip password authentication.")
(home-page "https://github.com/AlynxZhou/showmethekey")
(license license:asl2.0)))
+
+(define-public show-me-the-key
+ (deprecated-package "show-me-the-key" showmethekey))
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;
@@ -4169,37 +4169,6 @@ (define-public xforms-gl
(synopsis
"GUI toolkit for X based on the X11 Xlib library, with OpenGL support")))
-(define-public show-me-the-key
- (package
- (name "show-me-the-key")
- (version "1.8.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AlynxZhou/showmethekey/")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256 (base32
- "1gvrri6kfywxk8hfchc66r6fpwlrcai2j227ib33w6503cx66rl9"))))
- (build-system meson-build-system)
- (inputs (list libevdev
- libinput
- gtk
- json-glib-minimal
- cairo
- pango
- libxkbcommon
- polkit))
- (native-inputs (list `(,glib "bin") ; for glib-compile-resources
- `(,gtk "bin") ; for gtk-update-icon-cache
- pkg-config))
- (home-page "https://github.com/AlynxZhou/showmethekey")
- (synopsis "Screencast tool to display pressed keys")
- (description "Show Me the Key is a screencast tool to display your keys
-and works under both Xorg and Wayland (via @code{libinput}), inspired by
-@code{python-screenkey}.")
- (license license:asl2.0)))
-
(define-public xxkb
(package
(name "xxkb")