[bug#76999,1/2] gnu: Add python-gguf-llama-cpp.

Message ID CH3PR84MB3424609A3E0E8CE70C8AF473C5D32@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
State New
Headers
Series gnu: llama-cpp: Update to 0.0.0-b4882. |

Commit Message

Morgan Smith March 13, 2025, 9:18 p.m. UTC
  * gnu/packages/machine-learning.scm (python-gguf-llama-cpp): New variable.

Change-Id: I1c1b5f5956e3acb380b56816d180f53243b741fa
---
 gnu/packages/machine-learning.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
  

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 246b004156..ee5feb58fc 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -6490,6 +6490,21 @@  (define-public python-gguf
     (description "A Python library for reading and writing GGUF & GGML format ML models.")
     (license license:expat)))
 
+(define-public python-gguf-llama-cpp
+  (package/inherit python-gguf
+    (version "0.16.0")
+    (source (package-source llama-cpp))
+    (propagated-inputs (list python-numpy python-pyyaml python-sentencepiece
+                             python-tqdm))
+    (native-inputs (list python-poetry-core))
+    (arguments
+     (substitute-keyword-arguments (package-arguments python-gguf)
+       ((#:phases phases #~%standard-phases)
+        #~(modify-phases #$phases
+            (add-after 'unpack 'chdir
+              (lambda _
+                (chdir "gguf-py")))))))))
+
 (define-public python-gymnasium
   (package
     (name "python-gymnasium")