[bug#76999,v3,1/2] gnu: python-gguf: Update to 0.16.0.

Message ID CH3PR84MB3424439AFECFE2F4F8855B99C5AA2@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
State New
Headers
Series [bug#76999,v3,1/2] gnu: python-gguf: Update to 0.16.0. |

Commit Message

Morgan Smith April 7, 2025, 11:19 p.m. UTC
  * gnu/packages/machine-learning.scm (python-gguf): Update to 0.16.0.
Change origin to git repository.  Run tests.

Change-Id: I1c1b5f5956e3acb380b56816d180f53243b741fa
---
 gnu/packages/machine-learning.scm | 47 +++++++++++++++++++------------
 1 file changed, 29 insertions(+), 18 deletions(-)


base-commit: 666a6cfd88b3e5106a9180e06ea128db8084be0e
  

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 3e68af3476..bd7a4fd81b 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -7041,24 +7041,35 @@  (define-public oneapi-dnnl-for-r-torch
         (base32 "1zyw5rd8x346bb7gac9a7x3saviw3zvp6aqz2z1l9sv163vmjfz6"))))))
 
 (define-public python-gguf
-  (package
-    (name "python-gguf")
-    (version "0.6.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "gguf" version))
-       (sha256
-        (base32 "0rbyc2h3kpqnrvbyjvv8a69l577jv55a31l12jnw21m1lamjxqmj"))))
-    (build-system pyproject-build-system)
-    (arguments
-      (list #:tests? #false))
-    (inputs (list poetry python-pytest))
-    (propagated-inputs (list python-numpy))
-    (home-page "https://ggml.ai")
-    (synopsis "Read and write ML models in GGUF for GGML")
-    (description "A Python library for reading and writing GGUF & GGML format ML models.")
-    (license license:expat)))
+  ;; They didn't tag the commit
+  (let ((commit "69050a11be0ae3e01329f11371ecb6850bdaded5"))
+    (package
+      (name "python-gguf")
+      (version "0.16.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ggml-org/llama.cpp")
+               (commit commit)))
+         (file-name (git-file-name name commit))
+         (sha256
+          (base32 "1563mbrjykwpsbhghhzi4h1qv9qy74gq5vq4xhs58zk0jp20c7zz"))))
+      (build-system pyproject-build-system)
+      (arguments
+       (list
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'chdir
+              (lambda _
+                (chdir "gguf-py"))))))
+      (propagated-inputs (list python-numpy python-pyyaml python-sentencepiece
+                               python-tqdm))
+      (native-inputs (list python-poetry-core python-pytest))
+      (home-page "https://ggml.ai")
+      (synopsis "Read and write ML models in GGUF for GGML")
+      (description "A Python library for reading and writing GGUF & GGML format ML models.")
+      (license license:expat))))
 
 (define-public python-gymnasium
   (package