diff mbox series

[bug#72082] gnu: gpxsee: Update to 13.22.

Message ID CH3PR84MB3424364918258728EA88946DC5A62@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#72082] gnu: gpxsee: Update to 13.22. | expand

Commit Message

Morgan Smith July 12, 2024, 7:30 p.m. UTC
* gnu/packages/gps.scm (gpxsee): Update to 13.22.
Use qt-build-system.  Use qt6 instead of qt5.

Change-Id: I9101a6f763be198549aca8e5aea95987b14e58e4
---
 gnu/packages/gps.scm | 53 ++++++++++++++++++++++----------------------
 1 file changed, 27 insertions(+), 26 deletions(-)

Comments

Ludovic Courtès July 18, 2024, 3:06 p.m. UTC | #1
Hi Morgan,

Morgan Smith <Morgan.J.Smith@outlook.com> skribis:

> * gnu/packages/gps.scm (gpxsee): Update to 13.22.
> Use qt-build-system.  Use qt6 instead of qt5.
>
> Change-Id: I9101a6f763be198549aca8e5aea95987b14e58e4

[...]

> +     (list
> +      #:qtbase qtbase
> +      #:tests? #f

In general we avoid disabling tests.  Could you investigate a bit as to
why tests are failing?  Then the usual approach is to tweak or skip
individual tests, and only as a last resort use #:tests? #f.  In either
case, there should be a comment explaining why we’re doing this.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 09a419d7e9..d78c581ad0 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -31,6 +31,7 @@  (define-module (gnu packages gps)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system scons)
+  #:use-module (guix build-system qt)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix utils)
   #:use-module (gnu packages)
@@ -51,6 +52,7 @@  (define-module (gnu packages gps)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages serialization)
   #:use-module (gnu packages sqlite)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml))
 
 (define-public gpsbabel
@@ -179,33 +181,32 @@  (define-public gama
 (define-public gpxsee
   (package
     (name "gpxsee")
-    (version "11.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/tumic0/GPXSee")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1klpjiqsvpvhlg5hsfjaszsyqr817hig9r7y7w4cp0kyn8z5fzfj"))))
-    (build-system gnu-build-system)
+    (version "13.22")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tumic0/GPXSee")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15m5rqky2fwsq5n6x531350x39wwhpv1hz56m1yfaxj7acxhb2p5"))))
+    (build-system qt-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           ;; Use lrelease to convert TS translation files into QM files.
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (for-each (lambda (file)
-                         (invoke "lrelease" file))
-                       (find-files "lang" "\\.ts"))
-             (invoke "qmake"
-                     (string-append "PREFIX="
-                                    (assoc-ref outputs "out"))))))))
-    (inputs
-     (list qtbase-5 qtlocation qtsvg-5))
-    (native-inputs
-     (list qttools-5))
+     (list
+      #:qtbase qtbase
+      #:tests? #f
+      #:phases #~(modify-phases %standard-phases
+                   (replace 'configure
+                     ;; Use lrelease to convert TS translation files into QM files.
+                     (lambda _
+                       (apply invoke "lrelease"
+                              (find-files "lang" ".*\\.ts"))
+                       (invoke "qmake"
+                               (string-append "PREFIX="
+                                              #$output)))))))
+    (inputs (list libxkbcommon qtbase qtpositioning qtserialport qtsvg))
+    (native-inputs (list qttools))
     (home-page "https://www.gpxsee.org")
     (synopsis "GPS log file viewer and analyzer")
     (description