[bug#76594,v3,3/4] gnu: quilt: Use standard check phase.

Message ID CH3PR84MB342430C4DF1A65E2F03E213CC5B02@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
State New
Headers
Series None |

Commit Message

Morgan Smith April 13, 2025, 5:39 p.m. UTC
  * gnu/packages/patchutils.scm (quilt): Use standard check phase.

Change-Id: I79cb2828a877b7b6ba3cf7b16a56f454ea44803d
---
 gnu/packages/patchutils.scm | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)
  

Patch

diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index ea784c5acd..3da1e7b3b4 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -206,7 +206,9 @@  (define-public quilt
                     ,(map cmd-path
                           (list "find" "grep" "mkdir")))))))
           (add-after 'compress-documentation 'check
-            (lambda _
+            (assoc-ref %standard-phases 'check))
+          (add-before 'check 'fix-check
+            (lambda* (#:key inputs #:allow-other-keys)
               (substitute* '("test/run" "test/edit.test")
                 (("/bin/sh") (which "sh"))
                 (("rm -rf") (string-append (which "rm") " -rf")))
@@ -232,12 +234,12 @@  (define-public quilt
                      (or (and=> (which cmd)
                                 (lambda (p) (string-append > p <)))
                          &))))
-              (let ((make (which "make")))
-                ;; Assert the installed 'quilt' can find utilities it needs.
-                (unsetenv "PATH")
-                ;; Used by some tests for access to internal "scripts"
-                (setenv "QUILT_DIR" (string-append #$output "/share/quilt"))
-                (invoke make "check")))))))
+              ;; Assert the installed 'quilt' can find utilities it needs by
+              ;; emptying PATH of everything except make.
+              (setenv "PATH" (string-append (assoc-ref inputs "make") "/bin"))
+
+              ;; Used by some tests for access to internal "scripts"
+              (setenv "QUILT_DIR" (string-append #$output "/share/quilt")))))))
     (home-page "https://savannah.nongnu.org/projects/quilt/")
     (synopsis "Script for managing patches to software")
     (description