[bug#77223]

Message ID CH3PR02MB97469F939BFDD484D71FF60F90AC2@CH3PR02MB9746.namprd02.prod.outlook.com
State New
Headers
Series [bug#77223] |

Commit Message

guix-patches--- via April 1, 2025, 6:38 a.m. UTC
  Hi Ian,

I do see the #:tests? suggestion in that patch. Regardless, I've attached an updated patch that fixes a small typo in a comment I had initially overlooked.

Best,
Spencer
  

Comments

Cayetano Santos April 1, 2025, 8:58 a.m. UTC | #1
You need to fix also the version field, as this is a non release package.

  (version (git-version "XXX" revision commit))
  

Patch

From 850e78f2a0f687566f5db44af9206b475a06089f Mon Sep 17 00:00:00 2001
From: Spencer King <spencer.king@wustl.edu>
Date: Fri, 21 Mar 2025 18:08:43 -0500
Subject: [PATCH] gnu: Add emacs-migemo.

* gnu/packages/emacs-xyz.scm (emacs-migemo): New variable.

Change-Id: I17da166c1d2bc149f73c9ffcdfb2eb850a0d5dd5
---
 gnu/packages/emacs-xyz.scm | 30 +++++++++++++++++++++++++++++-
 1 file changed, 29 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f7459c3c32..d370d1efd8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -145,7 +145,7 @@ 
 ;;; Copyright © 2024 Daniel Szmulewicz <daniel.szmulewicz@gmail.com>
 ;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
-;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
+;;; Copyright © 2024, 2025 Spencer King <spencer.king@wustl.edu>
 ;;; Copyright © 2024 emma thompson <bigbookofbug@proton.me>
 ;;; Copyright © 2024-2025 Liam Hupfer <liam@hpfr.net>
 ;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
@@ -6886,6 +6886,34 @@  (define-public emacs-kanji
 and limited version of the images provided by the KanjiVG project.")
       (license license:gpl3+))))
 
+(define-public emacs-migemo
+  (let ((commit "fbc16b57eace9bf25bcb325032c59c50b186b9d7")
+        (revision "1"))
+    (package
+      (name "emacs-migemo")
+      (version "20250228.324")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacs-jp/migemo")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "10d27jrmn7k4mqqd5cgqf8jwa0pq9yh2550b1r6lwmz6wx509552"))))
+      (build-system emacs-build-system)
+      (arguments
+       ;; no tests
+       (list
+        #:tests? #f))
+      (home-page "https://github.com/emacs-jp/migemo")
+      (synopsis
+       "Japanese incremental search through dynamic pattern expansion")
+      (description
+       "This package provides incremental searching through Japanese text through
+romanization for Emacs.")
+      (license license:gpl2+))))
+
 (define-public emacs-kbd
   ;; Package has no release.  Version is extracted from "Version:" keyword in
   ;; main file.

base-commit: 5bf7d80535720077aec104a9904480d08b9b4f2b
-- 
2.41.0