Commit Message
Hello,
Attached is an updated patch with the suggested changes. I have had issues using git send-email with my preferred email account due to required multi-factor authentication so I have always sent patches as attachments on plain text emails. This has been fine for other teams. Is there an option I could provide to git format-patch that would make these patches easier for you to work with?
Best,
Spencer
From 23d776ae4c463fb81feea7bc07388a7897622dcd Mon Sep 17 00:00:00 2001
From: Spencer King <spencer.king@wustl.edu>
Date: Fri, 21 Mar 2025 18:08:43 -0500
Subject: [PATCH] gnu: Add emacs-migemo.
* gnu/packages/emacs-xyz.scm (emacs-migemo): New variable.
Change-Id: I17da166c1d2bc149f73c9ffcdfb2eb850a0d5dd5
---
gnu/packages/emacs-xyz.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)
@@ -145,7 +145,7 @@
;;; Copyright © 2024 Daniel Szmulewicz <daniel.szmulewicz@gmail.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
-;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
+;;; Copyright © 2024, 2025 Spencer King <spencer.king@wustl.edu>
;;; Copyright © 2024 emma thompson <bigbookofbug@proton.me>
;;; Copyright © 2024-2025 Liam Hupfer <liam@hpfr.net>
;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
@@ -6886,6 +6886,34 @@ (define-public emacs-kanji
and limited version of the images provided by the KanjiVG project.")
(license license:gpl3+))))
+(define-public emacs-migemo
+ (let ((commit "fbc16b57eace9bf25bcb325032c59c50b186b9d7")
+ (revision "1"))
+ (package
+ (name "emacs-migemo")
+ (version "20250228.324")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-jp/migemo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10d27jrmn7k4mqqd5cgqf8jwa0pq9yh2550b1r6lwmz6wx509552"))))
+ (build-system emacs-build-system)
+ (arguments
+ ;; not tests
+ (list
+ #:tests? #f))
+ (home-page "https://github.com/emacs-jp/migemo")
+ (synopsis
+ "Japanese incremental search through dynamic pattern expansion")
+ (description
+ "This package provides incremental searching through Japanese text through
+romanization for Emacs.")
+ (license license:gpl2+))))
+
(define-public emacs-kbd
;; Package has no release. Version is extracted from "Version:" keyword in
;; main file.
base-commit: 5bf7d80535720077aec104a9904480d08b9b4f2b
--
2.41.0