[bug#77223] gnu: Add emacs-migemo.
Commit Message
Comments
Thanks for the patch.
Note that 1.9.2 dates back from 6 years ago, maybe packaging latest
revision from last month is a better option.
Could you include the no tests flag to comply with upcoming changes in
emacs packages ?
(arguments
;; no tests
(list #:tests? #false))
C.
From 487fdd6d5aa680673d8e7bea84cca0af6c169626 Mon Sep 17 00:00:00 2001
From: Spencer King <spencer.king@wustl.edu>
Date: Fri, 21 Mar 2025 18:08:43 -0500
Subject: [PATCH] gnu: Add emacs-migemo.
* gnu/packages/emacs-xyz.scm (emacs-migemo): New variable.
Change-Id: I17da166c1d2bc149f73c9ffcdfb2eb850a0d5dd5
---
gnu/packages/emacs-xyz.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)
@@ -145,7 +145,7 @@
;;; Copyright © 2024 Daniel Szmulewicz <daniel.szmulewicz@gmail.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
-;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
+;;; Copyright © 2024, 2025 Spencer King <spencer.king@wustl.edu>
;;; Copyright © 2024 emma thompson <bigbookofbug@proton.me>
;;; Copyright © 2024-2025 Liam Hupfer <liam@hpfr.net>
;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
@@ -6886,6 +6886,27 @@ (define-public emacs-kanji
and limited version of the images provided by the KanjiVG project.")
(license license:gpl3+))))
+(define-public emacs-migemo
+ (package
+ (name "emacs-migemo")
+ (version "1.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-jp/migemo")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yasamfvad4azyby8mqyr2laap3ppknwb7i9w84zw14qq7g7pq5w"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacs-jp/migemo")
+ (synopsis "Japanese incremental search through dynamic pattern expansion")
+ (description
+ "This package provides incremental searching through Japanese text through
+romanization for Emacs.")
+ (license license:gpl2+)))
+
(define-public emacs-kbd
;; Package has no release. Version is extracted from "Version:" keyword in
;; main file.
base-commit: 5bf7d80535720077aec104a9904480d08b9b4f2b
--
2.41.0