diff mbox series

[bug#73311] Add libliftoff

Message ID CAPfwWaijsPDW4kmZf_dB+A4p02SKcxLq8r8Vajz6e0Kruwxc2w@mail.gmail.com
State New
Headers show
Series [bug#73311] Add libliftoff | expand

Commit Message

The Man Sept. 17, 2024, 2:43 a.m. UTC

Comments

The Man Sept. 22, 2024, 7:22 p.m. UTC | #1
My apologies. I did not consider the format of the patch could cause an
issue. I will consider better means of submitting patches in the future,
instead of through my Gmail.

On Sun, Sep 22, 2024, 9:11 AM Steve George <steve@futurile.net> wrote:

> Hi 'The Man',
>
> Thanks for your contribution! Just be aware that it wasn't in the correct
> format so the CI system couldn't automatically build it. If it doesn't
> build a committer is less likely to take the time to look at it. Please
> have a look at the manual at the section preparing a patch (
> https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html)
> when you send your next contribution :-). Hopefully it will build
> automatically and a committer will have time to review it.
>
> Review:
>   * submission: corrected patch format
>   * submission: checked source code hash
>   * submission: checked license, patch applies, build/reproducibility
>   * added Reviewed-by trailer
>   * re-roll to trigger QA build
>
> The Man (1):
>   gnu: Add libliftoff.
>
>  gnu/packages/freedesktop.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
>
> base-commit: b7c94d528875415ea7ec6225d88a6b3d55fa2e14
> --
> 2.46.0
>
>
>
>
>
Andreas Enge Sept. 26, 2024, 7:45 a.m. UTC | #2
QA does not seem to work right now. Given that the patch is more than
a week old and has been reviewed and that the package builds for me,
I take the liberty to apply it.

Thanks for the package and the review,

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cb1d625d24..f6e04ee88c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3296,3 +3296,27 @@  (define-public libdecor
 window decorations for them.  It aims to provide multiple backends that
 implements the decoration drawing.")
     (license license:expat)))
+
+(define-public libliftoff
+  (package
+    (name "libliftoff")
+    (version "0.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/emersion/libliftoff")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+              (base32
+                "163g8ndsbma7acy2k9mrnvlpb7yi4431hgkx1gygkafgwpq1ii1x"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list libdrm))
+    (home-page "https://gitlab.freedesktop.org/emersion/libliftoff")
+    (synopsis "Lightweight KMS plane library")
+    (description
+    "Libliftoff eases the use of KMS planes from userspace without standing in your
+way.  Users create \"virtual planes\" called layers, set KMS properties on them,
+and libliftoff will pick hardware planes for these layers if possible.")
+    (license license:expat)))