diff mbox series

[bug#73311] Add libliftoff

Message ID CAPfwWaijsPDW4kmZf_dB+A4p02SKcxLq8r8Vajz6e0Kruwxc2w@mail.gmail.com
State New
Headers show
Series [bug#73311] Add libliftoff | expand

Commit Message

The Man Sept. 17, 2024, 2:43 a.m. UTC

diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cb1d625d24..f6e04ee88c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3296,3 +3296,27 @@  (define-public libdecor
 window decorations for them.  It aims to provide multiple backends that
 implements the decoration drawing.")
     (license license:expat)))
+
+(define-public libliftoff
+  (package
+    (name "libliftoff")
+    (version "0.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/emersion/libliftoff")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+              (base32
+                "163g8ndsbma7acy2k9mrnvlpb7yi4431hgkx1gygkafgwpq1ii1x"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list libdrm))
+    (home-page "https://gitlab.freedesktop.org/emersion/libliftoff")
+    (synopsis "Lightweight KMS plane library")
+    (description
+    "Libliftoff eases the use of KMS planes from userspace without standing in your
+way.  Users create \"virtual planes\" called layers, set KMS properties on them,
+and libliftoff will pick hardware planes for these layers if possible.")
+    (license license:expat)))