diff mbox series

[bug#73135] Enable parallel tests for GTK

Message ID CAPfwWagUzJd_v+n2JR=P-yhutJ3VudHeJ+mLeXgKJGaCv3prcw@mail.gmail.com
State New
Headers show
Series [bug#73135] Enable parallel tests for GTK | expand

Commit Message

The Man Sept. 9, 2024, 12:55 a.m. UTC
In the middle of testing a set of patches that caused a large number of
rebuilds, I noticed the gtk package was taking an obscenely long time to
run checks. Upon inspection I found out it was not running tests as
parallel.
For example, https://ci.guix.gnu.org/build/5623913/details took >3000!
seconds.
The fix is obvious and will save time on future rebuilds.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 3d4766713d..f0f6a0cd9a 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1195,6 +1195,7 @@  (define-public gtk
                                         (string=? (%current-system) "aarch64-linux"))
                                    "--no-suite=wayland_gles2_failing"
                                    "--no-suite=wayland_gles_failing"))
+      #:parallel-tests? #t
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file