diff mbox series

[bug#73135] Enable parallel tests for GTK

Message ID CAPfwWagUzJd_v+n2JR=P-yhutJ3VudHeJ+mLeXgKJGaCv3prcw@mail.gmail.com
State New
Headers show
Series [bug#73135] Enable parallel tests for GTK | expand

Commit Message

The Man Sept. 9, 2024, 12:55 a.m. UTC
In the middle of testing a set of patches that caused a large number of
rebuilds, I noticed the gtk package was taking an obscenely long time to
run checks. Upon inspection I found out it was not running tests as
parallel.
For example, https://ci.guix.gnu.org/build/5623913/details took >3000!
seconds.
The fix is obvious and will save time on future rebuilds.

Comments

Ludovic Courtès Oct. 4, 2024, 3:14 p.m. UTC | #1
Hi,

The Man <squishypinkelephant@gmail.com> skribis:

> In the middle of testing a set of patches that caused a large number of
> rebuilds, I noticed the gtk package was taking an obscenely long time to
> run checks. Upon inspection I found out it was not running tests as
> parallel.
> For example, https://ci.guix.gnu.org/build/5623913/details took >3000!
> seconds.
> The fix is obvious and will save time on future rebuilds.
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 3d4766713d..f0f6a0cd9a 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -1195,6 +1195,7 @@ (define-public gtk
>                                          (string=? (%current-system) "aarch64-linux"))
>                                     "--no-suite=wayland_gles2_failing"
>                                     "--no-suite=wayland_gles_failing"))
> +      #:parallel-tests? #t

I wonder why #:parallel-tests? defaults to #f in ‘meson-build-system’,
contrary to what other build systems do.

I think we should create a branch where we change it to #t, and merge it
once we’re done rebuilding all the packages and fixing any relevant
failure.

Would you like to give that a try?

Thanks,
Ludo’.
The Man Oct. 4, 2024, 4:05 p.m. UTC | #2
Sounds like a good idea to me.

On Fri, Oct 4, 2024, 10:14 AM Ludovic Courtès <ludo@gnu.org> wrote:

> Hi,
>
> The Man <squishypinkelephant@gmail.com> skribis:
>
> > In the middle of testing a set of patches that caused a large number of
> > rebuilds, I noticed the gtk package was taking an obscenely long time to
> > run checks. Upon inspection I found out it was not running tests as
> > parallel.
> > For example, https://ci.guix.gnu.org/build/5623913/details took >3000!
> > seconds.
> > The fix is obvious and will save time on future rebuilds.
> > diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> > index 3d4766713d..f0f6a0cd9a 100644
> > --- a/gnu/packages/gtk.scm
> > +++ b/gnu/packages/gtk.scm
> > @@ -1195,6 +1195,7 @@ (define-public gtk
> >                                          (string=? (%current-system)
> "aarch64-linux"))
> >                                     "--no-suite=wayland_gles2_failing"
> >                                     "--no-suite=wayland_gles_failing"))
> > +      #:parallel-tests? #t
>
> I wonder why #:parallel-tests? defaults to #f in ‘meson-build-system’,
> contrary to what other build systems do.
>
> I think we should create a branch where we change it to #t, and merge it
> once we’re done rebuilding all the packages and fixing any relevant
> failure.
>
> Would you like to give that a try?
>
> Thanks,
> Ludo’.
>
Maxim Cournoyer Oct. 5, 2024, 12:36 p.m. UTC | #3
Hi,

The Man <squishypinkelephant@gmail.com> writes:

> Sounds like a good idea to me.

Implemented!  See: https://ci.guix.gnu.org/jobset/meson-parallel-tests

It hasn't started building anything yet (it's buildin guix at that
revision for now).

There's an RSS feed to keep track of it:
https://ci.guix.gnu.org/events/rss/?specification=meson-parallel-tests
Maxim Cournoyer Oct. 12, 2024, 5:34 a.m. UTC | #4
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hi,
>
> The Man <squishypinkelephant@gmail.com> writes:
>
>> Sounds like a good idea to me.
>
> Implemented!  See: https://ci.guix.gnu.org/jobset/meson-parallel-tests
>
> It hasn't started building anything yet (it's buildin guix at that
> revision for now).
>
> There's an RSS feed to keep track of it:
> https://ci.guix.gnu.org/events/rss/?specification=meson-parallel-tests

No issues whatsoever found:
https://ci.guix.gnu.org/jobset/meson-parallel-tests

Will prepare the branch merge request and close this one.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 3d4766713d..f0f6a0cd9a 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1195,6 +1195,7 @@  (define-public gtk
                                         (string=? (%current-system) "aarch64-linux"))
                                    "--no-suite=wayland_gles2_failing"
                                    "--no-suite=wayland_gles_failing"))
+      #:parallel-tests? #t
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file