[bug#33099] gnu: Add r-aspi.

Message ID CAPNLzUOCRHK6JHNYUPcy4eXkKSGWckXc7WShZRkrogLCVPJiUA@mail.gmail.com
State Accepted, archived
Headers show
Series [bug#33099] gnu: Add r-aspi. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Laura Lazzati Oct. 23, 2018, 2:47 p.m. UTC
On Tue, Oct 23, 2018 at 9:53 AM Björn Höfling
<bjoern.hoefling@bjoernhoefling.de> wrote:
>
> On Tue, 23 Oct 2018 07:16:00 -0300
> Laura Lazzati <laura.lazzati.15@gmail.com> wrote:
>
> >
>
> Hi Laura,
>
> I noted three things, sorry this wasn't mentioned before:
>
> 1) Your name in the commit is:
>
> Author: laura <laura.lazzati.15@gmail.com>  2018-10-23 06:59:22
>
> Is that intended or do you prefer the full name in capitals (i.e.
> "Laura Lazzati", as you have set in your emails)?
>
> If not, set the name correctly with
>
> git config --global user.name "Laura Lazzati"
It was intentional, but I have already corrected it.
>
> 2) Add a Copyright line for yourself, just copy any other from the file:
>
> ;;; Copyright © 2018 Name <email> ...
>
> 3) Change the Homepage to use HTTPS.
>
> Otherwise, LGTM ("Looks good to me").
>
> If you decide on 1) then I think a committer could add/correct these for
> you instead of endlessly sending out new patches.
>
> Thanks!
>
> Björn
Here goes hope the last version. When approved I have some questions
to ask :), most of them to improve future patches
Regards,
Laura

Comments

Gábor Boskovits Oct. 23, 2018, 6:29 p.m. UTC | #1
Hello Laura,

Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont: 2018.
okt. 23., K, 16:48):
>
> On Tue, Oct 23, 2018 at 9:53 AM Björn Höfling
> <bjoern.hoefling@bjoernhoefling.de> wrote:

> Here goes hope the last version. When approved I have some questions
> to ask :), most of them to improve future patches

This patch seems to be incomplete. Most probably it is meant to be appiled on
another patch. You can squash multiple commits to one, and get a
single commit and
a single patch.

The patch format is right now, so please keep sending them as attachment.

> Regards,
> Laura
Best regards,
g_bor
Björn Höfling Oct. 23, 2018, 7:33 p.m. UTC | #2
On Tue, 23 Oct 2018 20:29:22 +0200
Gábor Boskovits <boskovits@gmail.com> wrote:

> Hello Laura,
> 
> Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont: 2018.
> okt. 23., K, 16:48):
> >
> > On Tue, Oct 23, 2018 at 9:53 AM Björn Höfling
> > <bjoern.hoefling@bjoernhoefling.de> wrote:  
> 
> > Here goes hope the last version. When approved I have some questions
> > to ask :), most of them to improve future patches  
> 
> This patch seems to be incomplete. Most probably it is meant to be
> appiled on another patch. You can squash multiple commits to one, and
> get a single commit and
> a single patch.

I case you don't know, you can use git rebase -i in order to do that.

As you have probably two linarly consequtive commits, a

git rebase -i HEAD~2 

should do it. Read more here:

https://git-scm.com/docs/git-rebase#_interactive_mode

Björn
Laura Lazzati Oct. 23, 2018, 8:04 p.m. UTC | #3
On Tue, Oct 23, 2018 at 4:33 PM Björn Höfling
<bjoern.hoefling@bjoernhoefling.de> wrote:
>
> On Tue, 23 Oct 2018 20:29:22 +0200
> Gábor Boskovits <boskovits@gmail.com> wrote:
>
> > Hello Laura,
> >
> > Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont: 2018.
> > okt. 23., K, 16:48):
> > >
> > > On Tue, Oct 23, 2018 at 9:53 AM Björn Höfling
> > > <bjoern.hoefling@bjoernhoefling.de> wrote:
> >
> > > Here goes hope the last version. When approved I have some questions
> > > to ask :), most of them to improve future patches
> >
> > This patch seems to be incomplete. Most probably it is meant to be
> > appiled on another patch. You can squash multiple commits to one, and
> > get a single commit and
> > a single patch.
>
> I case you don't know, you can use git rebase -i in order to do that.
>
> As you have probably two linarly consequtive commits, a
>
> git rebase -i HEAD~2
>
> should do it. Read more here:
>
> https://git-scm.com/docs/git-rebase#_interactive_mode
I was reading a tutorial mentioning that.
I managed to do so, and after that made a commit --amend to adjust my
git username - I applied the changes after the first commit.
Thanks for answering on your holiday day :)

>
> Björn

Regards,
Laura
Björn Höfling Oct. 23, 2018, 8:38 p.m. UTC | #4
On Tue, 23 Oct 2018 17:04:16 -0300
Laura Lazzati <laura.lazzati.15@gmail.com> wrote:

> On Tue, Oct 23, 2018 at 4:33 PM Björn Höfling
> <bjoern.hoefling@bjoernhoefling.de> wrote:
> >
> > On Tue, 23 Oct 2018 20:29:22 +0200
> > Gábor Boskovits <boskovits@gmail.com> wrote:
> >
> > > Hello Laura,
> > >
> > > Laura Lazzati <laura.lazzati.15@gmail.com> ezt írta (időpont:
> > > 2018. okt. 23., K, 16:48):
> > > >
> > > > On Tue, Oct 23, 2018 at 9:53 AM Björn Höfling
> > > > <bjoern.hoefling@bjoernhoefling.de> wrote:
> > >
> > > > Here goes hope the last version. When approved I have some
> > > > questions to ask :), most of them to improve future patches
> > >
> > > This patch seems to be incomplete. Most probably it is meant to be
> > > appiled on another patch. You can squash multiple commits to one,
> > > and get a single commit and
> > > a single patch.
> >
> > I case you don't know, you can use git rebase -i in order to do
> > that.
> >
> > As you have probably two linarly consequtive commits, a
> >
> > git rebase -i HEAD~2
> >
> > should do it. Read more here:
> >
> > https://git-scm.com/docs/git-rebase#_interactive_mode
> I was reading a tutorial mentioning that.
> I managed to do so, and after that made a commit --amend to adjust my
> git username - I applied the changes after the first commit.
> Thanks for answering on your holiday day :)

LGTM.

Björn
Gábor Boskovits Oct. 23, 2018, 9:41 p.m. UTC | #5
Thank you for all!

Pushed to master as b55697fbb430ae9a973eeae91f09213d1e603a9e.
Laura Lazzati Oct. 24, 2018, 1:08 a.m. UTC | #6
On Tue, Oct 23, 2018 at 6:42 PM Gábor Boskovits <boskovits@gmail.com> wrote:
>
> Thank you for all!
>
> Pushed to master as b55697fbb430ae9a973eeae91f09213d1e603a9e.

Yeah :)
Regards!
Laura
Björn Höfling Oct. 24, 2018, 2:42 a.m. UTC | #7
On Tue, 23 Oct 2018 22:08:04 -0300
Laura Lazzati <laura.lazzati.15@gmail.com> wrote:

> On Tue, Oct 23, 2018 at 6:42 PM Gábor Boskovits <boskovits@gmail.com>
> wrote:
> >
> > Thank you for all!
> >
> > Pushed to master as b55697fbb430ae9a973eeae91f09213d1e603a9e.  
> 
> Yeah :)
> Regards!
> Laura

Congratulations!

Björn

Patch

From 0c5eba8ab24bb55f888d630eeccda604558cdefe Mon Sep 17 00:00:00 2001
From: Laura Lazzati <laura.lazzati.15@gmail.com>
Date: Tue, 23 Oct 2018 11:38:34 -0300
Subject: [PATCH] gnu: Add r-aspi.

* gnu/packages/cran.scm (r-aspi): New variable.
---
 gnu/packages/cran.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b9b2f3baa..73680a745 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2018 Charlie Ritter <chewzeirta@posteo.net>
 ;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
 ;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6269,7 +6270,7 @@  observation.")
         (base32 "0rhvxw243vvdv3hxa6pi343gcjc2cbxq1jzqirl9k1l4i3897l87"))))
     (build-system r-build-system)
     (home-page
-     "http://cran.r-project.org/web/packages/aspi/")
+     "https://cran.r-project.org/web/packages/aspi/")
     (synopsis
      "Analysis of symmetry of parasitic infections")
     (description
-- 
2.17.1