[bug#33099] gnu: Add r-aspi.

Message ID CAPNLzUNaODPQz-AQCviTtrTPtdvET5c-EsgYeFNR39t8y2zvHw@mail.gmail.com
State Superseded, archived
Headers show
Series [bug#33099] gnu: Add r-aspi. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Laura Lazzati Oct. 23, 2018, 10:16 a.m. UTC

Comments

Björn Höfling Oct. 23, 2018, 12:53 p.m. UTC | #1
On Tue, 23 Oct 2018 07:16:00 -0300
Laura Lazzati <laura.lazzati.15@gmail.com> wrote:

> 

Hi Laura,

I noted three things, sorry this wasn't mentioned before:

1) Your name in the commit is:

Author: laura <laura.lazzati.15@gmail.com>  2018-10-23 06:59:22

Is that intended or do you prefer the full name in capitals (i.e.
"Laura Lazzati", as you have set in your emails)?

If not, set the name correctly with 

git config --global user.name "Laura Lazzati"

2) Add a Copyright line for yourself, just copy any other from the file:

;;; Copyright © 2018 Name <email> ...

3) Change the Homepage to use HTTPS.

Otherwise, LGTM ("Looks good to me").

If you decide on 1) then I think a committer could add/correct these for
you instead of endlessly sending out new patches.

Thanks!

Björn

Patch

From 1c8a74481f93b7eb22d11a77062c0c5544e05d8d Mon Sep 17 00:00:00 2001
From: laura <laura.lazzati.15@gmail.com>
Date: Tue, 23 Oct 2018 01:59:22 -0300
Subject: [PATCH] gnu: Add r-aspi.

* gnu/packages/cran.scm (r-aspi): New variable.
---
 gnu/packages/cran.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index efcc2dccb..b9b2f3baa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6256,3 +6256,23 @@  a header row or not.  The dataset should contain only one independent variable
 (x) and one dependent variable (y) and can contain a weight for each
 observation.")
     (license license:gpl2)))
+
+(define-public r-aspi
+  (package
+    (name "r-aspi")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "aspi" version))
+       (sha256
+        (base32 "0rhvxw243vvdv3hxa6pi343gcjc2cbxq1jzqirl9k1l4i3897l87"))))
+    (build-system r-build-system)
+    (home-page
+     "http://cran.r-project.org/web/packages/aspi/")
+    (synopsis
+     "Analysis of symmetry of parasitic infections")
+    (description
+     "This package provides tools for the analysis and visualization of bilateral
+      asymmetry in parasitic infections.")
+    (license license:gpl3+)))
-- 
2.17.1