From dcc51bcbb8d0e831603cf1416570f8b418795c67 Mon Sep 17 00:00:00 2001
From: remimimimimi <valent.xarin@gmail.com>
Date: Wed, 9 Mar 2022 23:38:58 +0300
Subject: [PATCH] gnu: Add font-google-roboto-mono
---
gnu/packages/fonts.scm | 40 +++++++++++++++++++++++++++++++++++++---
1 file changed, 37 insertions(+), 3 deletions(-)
@@ -837,6 +837,40 @@ (define-public font-google-roboto
visual language \"Material Design\".")
(license license:asl2.0)))
+(define-public font-google-roboto-mono
+ (package
+ (name "font-google-roboto-mono")
+ (version "2.136")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/googlefonts/RobotoMono")
+ (commit "8f651634e746da6df6c2c0be73255721d24f2372")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00ddmr7yvb9isakfvgv6g74m80fmg81dmh1hrrdyswapaa7858a5"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/googlefonts/RobotoMono")
+ (synopsis "Monospaced Roboto font")
+ (description
+ "Roboto Mono is a monospaced addition to the Roboto type family.
+Like the other members of the Roboto family, the fonts are optimized for readability
+on screens across a wide variety of devices and reading environments. While the
+monospaced version is related to its variable width cousin, it doesn’t hesitate to
+change forms to better fit the constraints of a monospaced environment. For example,
+narrow glyphs like ‘I’, ‘l’ and ‘i’ have added serifs for more even texture while
+wider glyphs are adjusted for weight. Curved caps like ‘C’ and ‘O’ take on the
+straighter sides from Roboto Condensed. Special consideration is given to glyphs
+important for reading and writing software source code. Letters with similar shapes
+are easy to tell apart. Digit ‘1’, lowercase ‘l’ and capital ‘I’ are easily
+differentiated as are zero and the letter ‘O’. Punctuation important for code has
+also been considered. For example, the curly braces ‘{ }’ have exaggerated points
+to clearly differentiate them from parenthesis ‘( )’ and braces ‘[ ]’. Periods and
+commas are also exaggerated to identify them more quickly. The scale and weight of
+symbols commonly used as operators have also been optimized.")
+ (license license:asl2.0)))
+
(define-public font-borg-sans-mono
(package
(name "font-borg-sans-mono")
@@ -985,8 +1019,8 @@ (define-public font-adobe-source-code-pro
;; The upstream tag uses "/" between the roman and italic
;; versions, so substitute our "-" separator here.
#f "((R-ro)|(R-it))(-)" version
- 'pre 1 "/" 'post
- ))))
+ 'pre 1 "/" 'post))))
+
(file-name (git-file-name name version))
(sha256
(base32 "1lqchm8z0ah5y675ycmciqvr8y1v1gcj22ysfs443gm291vy0z4v"))))
@@ -1985,7 +2019,7 @@ (define-public font-dseg
#\.)))
(for-each (lambda (f) (install-file f truetype-dir))
(find-files "." "\\.ttf$"))
- #t)))))))
+ #t)))))))
(home-page "https://www.keshikan.net/fonts-e.html")
(synopsis "DSEG: 7-segment and 14-segment fonts")
(description
base-commit: 256703fa6cb0b27bd947315a206d42d500dc20c6
--
2.34.0