[bug#33334] :gnu:add ne:the nice editor

Message ID CAOYpmvq9s+N1yoObOFVN+mCJwWDwTSmco6fJNC3UVq9X3yJL6w@mail.gmail.com
State Accepted
Headers show
Series [bug#33334] :gnu:add ne:the nice editor | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

guy fleury iteriteka Jan. 6, 2019, 2:48 p.m. UTC
hi swedebugia,

sorry for the long delay,

here is the update patch.
i follow your sugestion .
but i don't know what others think.
feel free to change synopsis and description.

thanks,

Le jeu. 3 janv. 2019 à 17:16, swedebugia <swedebugia@riseup.net> a écrit :

> On 2018-11-10 22:32, swedebugia wrote:
> > Additionally:
> >
> > On 2018-11-10 10:25, guy fleury wrote:
> >> +    (description
> >> +   "ne is a free text editor based on the POSIX standard,
> >> +    it is easy to use it and fully configurable")
> >
> > We don't mention that it is free because in Guix all packages are free.
> > What about:
> >
> > "ne is fast, small, powerful and simple text editor that can be fully
> > configured.  It has a simple scripting language where scripts can be
> > easily generated and played."
> >
>
> Could you update the patch?
>
> --
> Cheers Swedebugia
>

Patch

From 6eca8e778bcba61280a67a5b4d603cf1416f77db Mon Sep 17 00:00:00 2001
From: guy fleury iteriteka <hoonandon@gmail.com>
Date: Sun, 6 Jan 2019 15:31:21 +0100
Subject: [PATCH] gnu: Add ne

---
 gnu/packages/nano.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/nano.scm b/gnu/packages/nano.scm
index 057e8c3bd..c64a3ed7e 100644
--- a/gnu/packages/nano.scm
+++ b/gnu/packages/nano.scm
@@ -22,6 +22,7 @@ 
 (define-module (gnu packages nano)
   #:use-module (guix licenses)
   #:use-module (gnu packages gettext)
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages ncurses)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -51,3 +52,40 @@  basic editing, it supports: undo/redo, syntax highlighting, spell checking,
 justifying, auto-indentation, bracket matching, interactive search-and-replace
 (with regular expressions), and the editing of multiple files.")
     (license gpl3+))) ; some files are under GPLv2+
+
+(define-public ne
+  (package
+    (name "ne")
+    (version "3.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://ne.di.unimi.it/ne-" version
+                           ".tar.gz"))
+       (sha256
+        (base32
+         "06qk3cqxyn098i1yn686bigpgh8vrrnj0qpkrgs6zwnq42s1y0d2"))
+       (modules '((guix build utils)))
+       (snippet
+        ;; use ncurses instead of curses
+        '(begin
+           (substitute* "src/makefile"
+             (("-lcurses") "-lncurses"))
+           #t))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ;; no tests
+       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+                          "CC=gcc")
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)))) ;;no configure script used
+    (inputs
+     `(("ncurses" ,ncurses)
+       ("perl" ,perl))) ;;needed by some scripts in source code
+    (synopsis "Small, fast text editor")
+    (description
+     "NE is fast, small, powerful and simple text editor that can be fully
+configured.  It has a simple scripting language where scripts can be easily
+generated and played.")
+    (home-page "http://ne.di.unimi.it/ne")
+    (license gpl3)))
-- 
2.19.2