diff mbox series

[bug#46375,5/5] On the way of packing astropy

Message ID CAO+9K5reQ6o+m7yURh=sbk=v_u8P-q0DAigtJTPNFyndJZcxbw@mail.gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

Sharlatan Hellseher Feb. 7, 2021, 11:45 p.m. UTC
Hi Guix team!

Here is a new bunch of patches adding chain of Astropy inputs.

One related issue is https://issues.guix.gnu.org/46324 which requires upgrade of
semantic_version update to make build possible for python-asdf
https://github.com/asdf-format/asdf/blob/master/setup.cfg#L28


--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.

Comments

Guillaume Le Vaillant Feb. 19, 2021, 10:08 a.m. UTC | #1
Patches pushed as 9daa9f2a6f32ae01c1a4b65d866809d5318c04e8 and following
with some modifications.
Thanks.
diff mbox series

Patch

From 5e32122576a1f270b56c9d9cbd9bb07bbdb445a6 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 7 Feb 2021 22:51:24 +0000
Subject: [PATCH 2/5] gnu: Add pytest-astropy

* gnu/packages/python-check.scm (python-pytest-astropy): New variable
---
 gnu/packages/python-check.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1305567b38..82ed5f56da 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -220,6 +220,38 @@  running pytest.  It can be used with packages that are not affiliated with the
 Astropy project, but is optimized for use with astropy-related projects.")
   (license license:bsd-3)))
 
+(define-public python-pytest-astropy
+  (package
+    (name "python-pytest-astropy")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-astropy" version))
+       (sha256
+        (base32 "18j6z6y2fvykmcs5z0mldhhaxxn6wzpnhlm2ps7m8r5z5kmh1631"))))
+    (build-system python-build-system)
+    (arguments
+     ;; No tests provided
+     '(#:tests? #f))
+    (native-inputs
+     `(("attrs" ,python-attrs)
+       ("hypothesis" ,python-hypothesis)
+       ("pytest" ,python-pytest)
+       ("pytest-arraydiff" ,python-pytest-arraydiff)
+       ("pytest-astropy-header" ,python-pytest-astropy-header)
+       ("pytest-cov" ,python-pytest-cov)
+       ("pytest-doctestplus" ,python-pytest-doctestplus)
+       ("pytest-filter-subpackage" ,python-pytest-filter-subpackage)
+       ("pytest-openfiles" ,python-pytest-openfiles)
+       ("pytest-remotedata" ,python-pytest-remotedata)))
+    (home-page "https://github.com/astropy/pytest-astropy")
+    (synopsis "Metapackage for all the testing machinery used by the Astropy Project")
+    (description
+     "This is a meta-package that pulls in the dependencies that are used by
+astropy related packages.")
+    (license license:bsd-3)))
+
 (define-public python-pytest-arraydiff
   (package
     (name "python-pytest-arraydiff")
-- 
2.30.0