diff mbox series

[bug#49152] : gnu: Add cl-posix-mqueue

Message ID CAO+9K5r_SXzhr0SyXgqMNWjziYdzPc4KxQyfrhWQQeC-3FR11g@mail.gmail.com
State Accepted
Headers show
Series [bug#49152] : gnu: Add cl-posix-mqueue | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher June 21, 2021, 11:13 a.m. UTC
-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.

Comments

Guillaume Le Vaillant June 22, 2021, 3:17 p.m. UTC | #1
I noticed that your patch doesn't substitute the full path of the librt
library (in 'src/spec.lisp'). I suppose it should work anyway because
librt comes with the glibc package which is probably always available in
some way, but I think it would be better to use the full path for
consistency.

Also, cl-ppcre should be a native input for the tests according to
'cl-posix-mqueue-tests.asd'.

Could you send an updated patch?
diff mbox series

Patch

From d605bc2ee21c7df1626db71f38b7d6fe05491e1a Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 21 Jun 2021 12:10:54 +0100
Subject: [PATCH] gnu: Add cl-posix-mqueue

* gnu/packages/lisp-xyx: (sbcl-cl-posix-mqueue, ecl-cl-posix-mqueue,
  cl-posix-mqueue): New variables
---
 gnu/packages/lisp-xyz.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1bd35d5812..50c118ee0c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17471,3 +17471,42 @@  Memory transactions give freedom from deadlocks, are immune to thread-safety
 bugs and race conditions, provide automatic roll-back on failure, and aim at
 resolving the tension between granularity and concurrency.")
      (license license:llgpl))))
+
+(define-public sbcl-cl-posix-mqueue
+  (let ((commit "8977370c7206d1f62bd1be80f4254af40654b83f")
+        (revision "1"))
+    (package
+      (name "sbcl-cl-posix-mqueue")
+      (version (git-version "0.1.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/xFA25E/cl-posix-mqueue")
+               (commit commit)))
+         (file-name (git-file-name "cl-posix-mqueue" version))
+         (sha256
+          (base32 "04519rg8vc782z097dzlb8nx0skab2fy2zd0m60r6mz2nw8xdvh6"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       `(#:test-asd-file "cl-posix-mqueue-tests.asd"))
+      (native-inputs
+       `(("rove" ,sbcl-rove)))
+      (inputs
+       `(("alexandira" ,sbcl-alexandria)
+         ("babel" ,sbcl-babel)
+         ("cffi" ,sbcl-cffi)
+         ("local-time" ,sbcl-local-time)))
+      (home-page "https://github.com/xFA25E/cl-posix-mqueue")
+      (synopsis "Common Lisp binding to POSIX mqueue")
+      (description
+"This package provides a Common Lisp bindings to POSIX message queue - an
+IPC (Inter-Process Communication) method that is easy to use and quick to
+setup.")
+      (license license:gpl3+))))
+
+(define-public ecl-cl-posix-mqueue
+  (sbcl-package->ecl-package sbcl-cl-posix-mqueue))
+
+(define-public cl-posix-mqueue
+  (sbcl-package->cl-source-package sbcl-cl-posix-mqueue))
-- 
2.32.0