diff mbox series

[bug#46251] Update parse-float to 0.0.0-2.3074765

Message ID CAO+9K5rQugq3jc1AvEdaB30r9fny-7t3xD0W1mtrwoEY8k1TUQ@mail.gmail.com
State Accepted
Headers show
Series [bug#46251] Update parse-float to 0.0.0-2.3074765 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Feb. 2, 2021, 12:41 a.m. UTC

Comments

Guillaume Le Vaillant Feb. 2, 2021, 9:43 a.m. UTC | #1
I removed the babel input which was not used anymore and pushed the
patch as 65454c1caa60c8f07833aa920648188ab6bbca85.
Thanks.
diff mbox series

Patch

From 4c0105c8be7f635e547fbadd93a8367086b5461d Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Tue, 2 Feb 2021 00:37:36 +0000
Subject: [PATCH] gnu: parse-float: Update to 0.0.0-2.3074765

* gnu/packages/listp-xyz.scm (sbcl-parse-float)
  [native-inputs] prove -> lisp-unit
  [arguments] enable tests
---
 gnu/packages/lisp-xyz.scm | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 7cfd4b2a6b..fdcfa0fe4e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2323,10 +2323,11 @@  pattern-matching-like, but a char-by-char procedural parser.")
   (sbcl-package->ecl-package sbcl-proc-parse))
 
 (define-public sbcl-parse-float
-  (let ((commit "2aae569f2a4b2eb3bfb5401a959425dcf151b09c"))
+  (let ((commit "3074765101e41222b6b624a66aaf1e6416379f9c")
+        (revision "2"))
     (package
       (name "sbcl-parse-float")
-      (version (git-version "0.0.0" "1" commit))
+      (version (git-version "0.0.0" revision commit))
       (source
        (origin
          (method git-fetch)
@@ -2334,23 +2335,22 @@  pattern-matching-like, but a char-by-char procedural parser.")
                (url "https://github.com/soemraws/parse-float")
                (commit commit)))
          (sha256
-          (base32
-           "08xw8cchhmqcc0byng69m3f5a2izc9y2290jzz2k0qrbibp1fdk7"))
+          (base32 "0jd2spawc3v8vzqf8ky4cngl45jm65fhkrdf20mf6dcbn3mzpkmr"))
          (file-name (git-file-name "proc-parse" version))))
       (build-system asdf-build-system/sbcl)
+      (arguments
+       ;; FIXME: https://github.com/soemraws/parse-float/issues/12
+       `(#:asd-systems '("parse-float" "parse-float-tests")))
+      (native-inputs
+       `(("lisp-unit" ,sbcl-lisp-unit)))
       (inputs
        `(("alexandria" ,sbcl-alexandria)
          ("babel" ,sbcl-babel)))
-      (native-inputs
-       `(("prove" ,sbcl-prove)))
-      (arguments
-       ;; TODO: Tests don't find "proc-parse-test", why?
-       `(#:tests? #f))
+      (home-page "https://github.com/soemraws/parse-float")
       (synopsis "Parse a floating point value from a string in Common Lisp")
       (description
        "This package exports the following function to parse floating-point
 values from a string in Common Lisp.")
-      (home-page "https://github.com/soemraws/parse-float")
       (license license:public-domain))))
 
 (define-public cl-parse-float
-- 
2.30.0