diff mbox series

[bug#46281,2/2] On the way of packing ViralityEngine

Message ID CAO+9K5rLDq5gKJKRO=p5=NXcxsxKGY9hu8oxMyHths_Q=8o5cQ@mail.gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

Sharlatan Hellseher Feb. 4, 2021, 1:48 a.m. UTC
Hi Guix team!

Other series of patches which adds: origin and specialization-store

Comments

Guillaume Le Vaillant Feb. 4, 2021, 1:37 p.m. UTC | #1
Patches pushed as 68608dd412c49a3372567b2d43633d9c7161ecbb and
following.
Thanks.
diff mbox series

Patch

From 55016b23986cf300373206bb45b0443456c41a7b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 4 Feb 2021 01:44:11 +0000
Subject: [PATCH 2/2] gnu: Add origin

* gnu/packages/lisp-xyz.scm (sbcl-origin, cl-origin, ecl-oring): New variables
---
 gnu/packages/lisp-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5cf066af0f..cecf29b207 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -8761,6 +8761,43 @@  respectively.")
 (define-public ecl-salza2
   (sbcl-package->ecl-package sbcl-salza2))
 
+(define-public sbcl-origin
+  (let ((commit "d646134302456408d6d43580bb05299f1695ab8e")
+        (revision "1"))
+    (package
+      (name "sbcl-origin")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.mfiano.net/mfiano/origin")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1n9aszaif3yh8prs5r8v51fbj4r5jd1a048mivd5yij3hplkm82b"))))
+      (build-system asdf-build-system/sbcl)
+      (native-inputs
+       `(("parachute" ,sbcl-parachute)))
+      (inputs
+       `(("golden-utils" ,sbcl-golden-utils)
+         ("specialization-store" ,sbcl-specialization-store)))
+      (home-page "https://git.mfiano.net/mfiano/origin")
+      (synopsis "Common Lisp graphics math library")
+      (description
+       "A native Common Lisp graphics math library with an emphasis on
+performance and correctness.
+
+This package provides 1 system: @code{ORIGIN}")
+      (license license:expat))))
+
+;; Time consumption build process on ECL 10min+
+(define-public ecl-origin
+  (sbcl-package->ecl-package sbcl-origin))
+
+(define-public cl-origin
+  (sbcl-package->cl-source-package sbcl-origin))
+
 (define-public sbcl-png-read
   (let ((commit "ec29f38a689972b9f1373f13bbbcd6b05deada88")
         (revision "1"))
-- 
2.30.0