diff mbox series

[bug#46160] Round 2

Message ID CAO+9K5rEqfRAUKNu8RGo9P0H8hpFwreaKP-f0DcWg+GyJb8OAg@mail.gmail.com
State New
Headers show
Series [bug#46160] Round 2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Feb. 4, 2021, 8:40 p.m. UTC
Hi Guix team!

I've cleaned up the patch a little bit and removed most of the CMake
flags as they are picked up when I add most of the dependencies in
`inputs'
diff mbox series

Patch

From d4edcdcd71cc2c47caf2511abeb1bf153434d25c Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 4 Feb 2021 20:36:32 +0000
Subject: [PATCH] gnu: Add plplot

* gnu/packages/maths.scm (plplot): New variable
---
 gnu/packages/maths.scm | 60 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 60 insertions(+)

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index eff1480e62..cfc57734da 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -107,6 +107,7 @@ 
   #:use-module (gnu packages llvm)
   #:use-module (gnu packages logging)
   #:use-module (gnu packages lua)
+  #:use-module (gnu packages geo)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages xorg)
@@ -131,6 +132,7 @@ 
   #:use-module (gnu packages tbb)
   #:use-module (gnu packages scheme)
   #:use-module (gnu packages shells)
+  #:use-module (gnu packages swig)
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tex)
@@ -954,6 +956,64 @@  plotting engine by third-party applications like Octave.")
     (license (license:fsf-free
               "http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright"))))
 
+(define-public plplot
+  ;; TODO: (Sharlatan-20210204T203350+0000): It needs to be split int some other
+  ;; logical package like plplot-gtk plplot-qt plplot-minimal etc. For now I try
+  ;; to include as much bindings as I could achieve.
+  (package
+    (name "plplot")
+    (version "5.15.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             ;; Official mirror in case Sourseforge blocks access
+             ;; (url "https://github.com/PLplot/PLplot")
+             (url "https://git.code.sf.net/p/plplot/plplot")
+             (commit (string-append name "-" version))))
+       (sha256
+        (base32 "0fn9j251zv9pwlqy30yv4flwcd0cbyxd1nn388n1k158jycw2i91"))
+       (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; NOTE: (Sharlatan-20210204T120351+0000): Tests failing on examples_cxx
+     `(#:tests? #f
+       #:configure-flags
+       (let ((out (assoc-ref %outputs "out")))
+         (list
+          ;; "-DBUILD_TEST=ON"
+          "-DENABLE_wxwidgets=ON"
+          "-DCMAKE_BUILD_TYPE=Release"
+          "-DCMAKE_SKIP_BUILD_RPATH=OFF"
+          (string-append "-DCMAKE_INSTALL_LIBDIR=" out "/lib")
+          (string-append "-DCMAKE_INSTALL_PREFIX=" out)))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("swig" ,swig)))
+    (inputs
+     `(("freetype", freetype)
+       ("gfortran" ,gfortran)
+       ("libltdl" ,libltdl)
+       ("lua", lua)
+       ("numpy", python-numpy)
+       ("octave", octave)
+       ("pango" ,pango)
+       ("perl", perl)
+       ("python", python)
+       ("qhull" ,qhull)
+       ("shapelib" ,shapelib)
+       ("tcl", tcl)
+       ("tk", tk)
+       ("wxwidgets" ,wxwidgets)
+       ("xml-dom" ,perl-xml-dom)
+       ("xml-dom" ,perl-xml-parser)))
+    (home-page "http://plplot.org/")
+    (synopsis "Scientific graphics plotting library")
+    (description
+     "PLplot is a cross-platform software package for creating scientific plots
+whose (UTF-8) plot symbols and text.")
+    (license license:lgpl2.0))) ; Other terms are in Copyright file
+
 (define-public gctp
   (package
     (name "gctp")
-- 
2.30.0