diff mbox series

[bug#46072] New variable - sextractor

Message ID CAO+9K5qu+MDi_T_4Ba=8EAAFVK3Uenm7ty9UdFsNsBGM7aExRw@mail.gmail.com
State Accepted
Headers show
Series [bug#46072] New variable - sextractor | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Jan. 24, 2021, 11:24 a.m. UTC
Hi Guix team!

This patch is one of the planed set of software for astronomy I'd like
to pack for Guix
https://github.com/Hellseher/guix-patches/blob/main/astronomy.org

Regards

--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.

Comments

Guillaume Le Vaillant Jan. 25, 2021, 5:06 p.m. UTC | #1
Patch pushed as b2d6f127c24787df00bffd918fa879842f933817.
Thanks.
Guillaume Le Vaillant Jan. 25, 2021, 5:09 p.m. UTC | #2
Patch pushed as b2d6f127c24787df00bffd918fa879842f933817.
Thanks.
diff mbox series

Patch

From 067fecb0a5b64d1dd17dcb0c4ef78687fe030645 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 24 Jan 2021 11:16:36 +0000
Subject: [PATCH] Add new sextractor

* gnu/packages/astronomy.scm (sextractor): New variable
---
 gnu/packages/astronomy.scm | 48 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9485fe600f..65f42df5df 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -156,6 +156,54 @@  header.")
 programs for the manipulation and analysis of astronomical data.")
     (license license:gpl3+)))
 
+(define-public sextractor
+  (package
+    (name "sextractor")
+    (version "2.25.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/astromatic/sextractor")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0q69n3nyal57h3ik2xirwzrxzljrwy9ivwraxzv9566vi3n4z5mw"))))
+    (build-system gnu-build-system)
+    ;; NOTE: (Sharlatan-20210124T103117+0000): Building with `atlas' is failing
+    ;; due to missing shared library which required on configure phase. Switch
+    ;; build to use `openblas' instead. It requires FFTW with single precision
+    ;; `fftwf'.
+    (arguments
+     `(#:configure-flags
+       (list
+        "--enable-openblas"
+        (string-append
+         "--with-openblas-libdir=" (assoc-ref %build-inputs "openblas") "/lib")
+        (string-append
+         "--with-openblas-incdir=" (assoc-ref %build-inputs "openblas") "/include")
+        (string-append
+         "--with-fftw-libdir=" (assoc-ref %build-inputs "fftw") "/lib")
+        (string-append
+         "--with-fftw-incdir=" (assoc-ref %build-inputs "fftw") "/include"))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
+    (inputs
+     `(("openblas" ,openblas)
+       ("fftw" ,fftwf)))
+    (home-page "http://www.astromatic.net/software/sextractor")
+    (synopsis "Extract catalogs of sources from astronomical images")
+    (description
+     "SExtractor is a program that builds a catalogue of objects from an
+astronomical image.  Although it is particularly oriented towards reduction of
+large scale galaxy-survey data, it can perform reasonably well on moderately
+crowded star fields.
+
+This package produces binaries: ldactoasc, sex")
+ (license license:gpl3)))
+
 (define-public stellarium
   (package
     (name "stellarium")
-- 
2.30.0