diff mbox series

[bug#46462,1/1] gnu: Add swappy

Message ID CAO+9K5qsy8auX9EhTrkakXi+R0uodfagnmqLP8VgXob5+u5ZZA@mail.gmail.com
State Accepted
Headers show
Series [bug#46462,1/1] gnu: Add swappy | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Feb. 12, 2021, 12:18 p.m. UTC

Comments

宋文武 Feb. 13, 2021, 2:43 a.m. UTC | #1
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> Subject: [PATCH] gnu: Add swappy
>
> * gnu/packages/image.scm (swappy): New variable
> [...]

Hello, I made a bit of changes:
- Add the end '.' to the commit messages.
- Remove 'meson-for-build' from native-for-build, as
'meson-build-system' bring it alreally.
- Use synopsis and description from its man page, which I find more
natural.

Then pushed, thank you!
diff mbox series

Patch

From 897c5f262977fbb65e1b21b27d80ca39efc7e8e2 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 12 Feb 2021 12:16:31 +0000
Subject: [PATCH] gnu: Add swappy

* gnu/packages/image.scm (swappy): New variable
---
 gnu/packages/image.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 339bd7dcf2..60a46eb2b9 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -28,6 +28,7 @@ 
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -51,6 +52,7 @@ 
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages build-tools)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages curl)
@@ -1820,6 +1822,36 @@  Features:
 @end itemize\n")
     (license license:gpl3+)))
 
+(define-public swappy
+  (package
+    (name "swappy")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jtheoof/swappy")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "14ac2jmnak7avcz0jhqjm30vk7pv3gq5aq5rdyh84k8c613kkicf"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("meson" ,meson-for-build)
+       ("scdoc" ,scdoc)
+       ("glib" ,glib "bin"))) ; for 'glib-compile-resources'
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("libnotify" ,libnotify)))
+    (home-page "https://github.com/jtheoof/swappy")
+    (synopsis "Wayland native snapshot editing tool, inspired by Snappy on macOS")
+    (description
+     "A Wayland native snapshot and editor tool, inspired by Snappy on macOS.
+Works great with grim, slurp and sway.  But can easily work with other screen
+copy tools that can output a final PNG image to stdout.")
+    (license license:expat)))
+
 (define-public gifsicle
   (package
    (name "gifsicle")
-- 
2.30.0