diff mbox series

[bug#46103] Add new - EyE

Message ID CAO+9K5qq7u2QekGgRL1s5Xetw-5XT4p19WYMyV-5cTU7xk0+4A@mail.gmail.com
State Accepted
Headers show
Series [bug#46103] Add new - EyE | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Jan. 25, 2021, 5:49 p.m. UTC

Comments

M Jan. 26, 2021, 7:51 a.m. UTC | #1
Hi Sharlatan,

Is there any particular reason a http:// URL is used
instead of a https://? I believe the latter is preferred.
Also, you can add a copyright line for yourself at the top
of the file. Otherwise, the package definition LGTM.

Greetings,
Maxime
Guillaume Le Vaillant Jan. 26, 2021, 9:11 a.m. UTC | #2
I changed the URLs to use https, fixed the license field and pushed the
patch as 51418c32d95d8188d8877616829f26479f1135c6.
diff mbox series

Patch

From 95776d9dbddf48be560c33df79945f7510787c0b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 25 Jan 2021 17:43:03 +0000
Subject: [PATCH] gnu: Add eye

* gnu/packages/astronomy.scm (eye): New variable
---
 gnu/packages/astronomy.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0e1a55481f..8eb74b44ae 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -88,6 +88,29 @@  in FITS files.")
     (license (license:non-copyleft "file://License.txt"
                           "See License.txt in the distribution."))))
 
+(define-public eye
+  (package
+    (name "eye")
+    (version "1.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://www.astromatic.net/download/"
+                           name "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32 "092qhzcbrkcfidbx4bv9wz42w297n80jk7a6kwyi9a3fjfz81d7k"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.astromatic.net/software/eye")
+    (synopsis "Small image feature detector using machine learning")
+    (description
+     "In EyE (Enhance Your Extraction) an artificial neural network connected to
+pixels of a moving window (retina) is trained to associate these input stimuli
+to the corresponding response in one or several output image(s).  The resulting
+filter can be loaded in SExtractor to operate complex, wildly non-linear filters
+on astronomical images.  Typical applications of EyE include adaptive filtering,
+feature detection and cosmetic corrections.")
+    (license license:gpl3+)))
+
 (define-public wcslib
   (package
     (name "wcslib")
-- 
2.30.0