diff mbox series

[bug#51795] : gnu: Add imppg

Message ID CAO+9K5qpSjF-FLYFdVPYEknM_ffhEJ78gLjaEe5WqwR1r8OqjQ@mail.gmail.com
State Accepted
Headers show
Series [bug#51795] : gnu: Add imppg | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Nov. 12, 2021, 9:22 p.m. UTC
successfully built /gnu/store/14nqbnzy6k91x8l98c9hid6l1dxcza60-imppg-0.6.4.drv


-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.

Comments

Nicolas Goaziou Dec. 5, 2021, 11:38 a.m. UTC | #1
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> successfully built
> /gnu/store/14nqbnzy6k91x8l98c9hid6l1dxcza60-imppg-0.6.4.drv

Thank you.

I applied it with the following minor change:

> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url (string-append "https://github.com/GreatAttractor/" name))

I hard-coded name into URL.

Regards,
diff mbox series

Patch

From 8ba2e65db5753bd6b4c57e9957ec66b8581e4d69 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 12 Nov 2021 21:21:12 +0000
Subject: [PATCH] gnu: Add imppg

* gnu/packages/astronomy.scm: (imppg): New variable.
---
 gnu/packages/astronomy.scm | 53 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fc8959faad..57f62dc24d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -32,6 +32,7 @@  (define-module (gnu packages astronomy)
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
@@ -56,6 +57,7 @@  (define-module (gnu packages astronomy)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages video)
+  #:use-module (gnu packages wxwidgets)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
@@ -986,6 +988,57 @@  (define-public sgp4
 It can be used to calculate the trajectory of satellites.")
       (license license:asl2.0))))
 
+(define-public imppg
+  (package
+    (name "imppg")
+    (version "0.6.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url (string-append "https://github.com/GreatAttractor/" name))
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "04synbmyz0hkipl1cdc26nr42r57v494yjw8pi4jx0jrxrawgj9h"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f ; No test provided
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (mkdir-p "build")
+             (chdir "build")
+             (invoke
+              "cmake"
+              "-G" "Unix Makefiles"
+              "-DCMAKE_BUILD_TYPE=Release"
+              (string-append "-DCMAKE_INSTALL_PREFIX=" (assoc-ref outputs "out"))
+              ".."))))))
+    (native-inputs
+     `(("boost" ,boost)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cfitsio" ,cfitsio)
+       ("freeimage" ,freeimage)
+       ("glew" ,glew)
+       ("wxwidgets" ,wxwidgets)))
+    (home-page "https://github.com/GreatAttractor/imppg")
+    (synopsis "Astronomical Image Post-Proccessor (ImPPG)")
+    (description
+     "ImPPG performs Lucy-Richardson deconvolution, unsharp masking, brightness
+normalization and tone curve adjustment.  It can also apply previously specified
+processing settings to multiple images.  All operations are performed using
+32-bit floating-point arithmetic.
+
+Supported input formats: FITS, BMP, JPEG, PNG, TIFF (most of bit depths and
+compression methods), TGA and more.  Images are processed in grayscale and can be
+saved as: BMP 8-bit; PNG 8-bit; TIFF 8-bit, 16-bit, 32-bit floating-point (no
+compression, LZW- or ZIP-compressed), FITS 8-bit, 16-bit, 32-bit
+floating-point.")
+     (license license:gpl3+)))
+
 (define-public indi
   (package
     (name "indi")
-- 
2.33.1