diff mbox series

[bug#48485,1/2] : gnu: Add shasht

Message ID CAO+9K5qmVdm+aE=dMWsHH80T-JAacd9AAVCHrwLQ+Q4_T==gnw@mail.gmail.com
State Accepted
Headers show
Series [bug#48485,1/2] : gnu: Add shasht | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher May 17, 2021, 7:54 p.m. UTC
-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.

Comments

Guillaume Le Vaillant May 18, 2021, 7:52 a.m. UTC | #1
Patches pushed as ff11a9f449e2f259faabebd075ce2ae1e13d27c2 and following
with a few modifications:
 - shasht: alexandria and parachute moved to native-inputs as they are
   only used for the tests.
 - common-lisp-jupyter: license changed to expat/MIT as this is what is
   indicated upstream.

Thanks.
Jack Hill May 18, 2021, 3:58 p.m. UTC | #2
Thanks for working on this. However, I have a question about the synopsis:

> +      (synopsis "Common Lisp JSON reading and writing for the Kzinti")

As a native American English speaker, I find Kzinti to be an obscure word. 
I didn't know what it meant when I first read it. Doing a search online 
wasn't that enlightening. The best thing I could fine talked about alien 
cats [0]. Do you think the synopsis could be improved in the future to 
more clearly say what the software is for and improve search results? 
Perhaps shortening it to "Common Lisp JSON reading and writing" would be 
sufficient?

[0] https://en.wikipedia.org/wiki/Kzin

Best,
Jack
Guillaume Le Vaillant May 18, 2021, 4:40 p.m. UTC | #3
Jack Hill <jackhill@jackhill.us> skribis:

> Thanks for working on this. However, I have a question about the synopsis:
>
>> +      (synopsis "Common Lisp JSON reading and writing for the Kzinti")
>
> As a native American English speaker, I find Kzinti to be an obscure word.
> I didn't know what it meant when I first read it. Doing a search online 
> wasn't that enlightening. The best thing I could fine talked about alien cats
> [0]. Do you think the synopsis could be improved in the future to more clearly
> say what the software is for and improve search results? Perhaps shortening it
> to "Common Lisp JSON reading and writing" would be sufficient?
>
> [0] https://en.wikipedia.org/wiki/Kzin
>
> Best,
> Jack

Before pushing Sharlatan's patch, I changed the synopsis to "Common Lisp
JSON reading and writing library". I also didn't know that word, found
that it was probably a reference to a cat-looking warrior from space in
a series of science fiction novels, and concluded that it was not
really related to JSON processing.
Jack Hill May 18, 2021, 4:50 p.m. UTC | #4
On Tue, 18 May 2021, Guillaume Le Vaillant wrote:

> Jack Hill <jackhill@jackhill.us> skribis:
>
>> Thanks for working on this. However, I have a question about the synopsis:
>>
>>> +      (synopsis "Common Lisp JSON reading and writing for the Kzinti")
>>
>> As a native American English speaker, I find Kzinti to be an obscure word.
>> I didn't know what it meant when I first read it. Doing a search online
>> wasn't that enlightening. The best thing I could fine talked about alien cats
>> [0]. Do you think the synopsis could be improved in the future to more clearly
>> say what the software is for and improve search results? Perhaps shortening it
>> to "Common Lisp JSON reading and writing" would be sufficient?
>>
>> [0] https://en.wikipedia.org/wiki/Kzin
>>
>> Best,
>> Jack
>
> Before pushing Sharlatan's patch, I changed the synopsis to "Common Lisp
> JSON reading and writing library". I also didn't know that word, found
> that it was probably a reference to a cat-looking warrior from space in
> a series of science fiction novels, and concluded that it was not
> really related to JSON processing.

Happy to here that I wasn't alone in thinking that. I guess it's time to 
`guix pull` and benefit from the new packages.

Thanks!
Jack
diff mbox series

Patch

From f99196cff24a7802f143797f7a842960fcdf2323 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 17 May 2021 20:32:18 +0100
Subject: [PATCH 1/2] gnu: Add shasht

* gnu/packages/lisp-xyz.scm (sbcl-shasht, ecl-shasht, cl-shasht): New variables.
---
 gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 64955a13f6..ce8c61eefe 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16644,3 +16644,36 @@  all kind of typesetting applications.")
 
 (define-public cl-typesetting
   (sbcl-package->cl-source-package sbcl-cl-typesetting))
+
+(define-public sbcl-shasht
+  (let ((commit "4055327ef8e2aaa8627892ab256350ff3cb15e3c")
+        (revision "1"))
+    (package
+      (name "sbcl-shasht")
+      (version (git-version "0.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/yitzchak/shasht.git")
+               (commit commit)))
+         (file-name (git-file-name "shasht" version))
+         (sha256
+          (base32 "01mh20s5gj0lajq45anxji77ykq1wcg72mn1y9a1k8i7q1ainjlr"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+         ("parachute" ,sbcl-parachute)
+         ("trivial-do" ,sbcl-trivial-do)))
+      (home-page "https://yitzchak.github.io/shasht/")
+      (synopsis "Common Lisp JSON reading and writing for the Kzinti")
+      (description
+       "This package provides a Common Lisp library to work with JSON file
+format.")
+      (license license:expat))))
+
+(define-public ecl-shasht
+  (sbcl-package->ecl-package sbcl-shasht))
+
+(define-public cl-shasht
+  (sbcl-package->cl-source-package sbcl-shasht))
-- 
2.31.1