diff mbox series

[bug#65041] gnu: clisp: Add threads support on x84_64-linux.

Message ID CAO+9K5qPxMw8zrP_74Mubsn9HD_NVcMr=DDqART57Lig50BXfw@mail.gmail.com
State New
Headers show
Series [bug#65041] gnu: clisp: Add threads support on x84_64-linux. | expand

Commit Message

Sharlatan Hellseher Aug. 31, 2023, 1:19 p.m. UTC
Hi Guillaume,

Andrew tried to build it on Raspberry Pi (ARM based) but it's failed
without that restriction. I had no chance to test on other platform
supported by Guix yet.
I'm including V2 of the patch which include minor adjustment for
target architecture detection simplification.

Thanks,
Oleg

On Mon, 28 Aug 2023 at 17:31, Guillaume Le Vaillant <glv@posteo.net> wrote:
>
> Hi.
>
> As clisp has over 1600 dependent packages, updating it should be done on
> a "lisp-team" branch which will be merged into the master branch if all
> goes well. However I can't do that right now as I'm on holiday until
> next week.
>
>
> Sharlatan Hellseher <sharlatanus@gmail.com> skribis:
>
> > * gnu/packages/lisp.scm (clisp)[arguments]: Add configuration options to
> > support threads on x86_64-linux system.
> > [...]
> > +                           ,@(if (string-prefix? "x86_64-linux"
> > +                                                 (or (%current-system)
> > +                                                     (%current-target-system)))
> > +                                 '("--enable-portability"
> > +                                   "--with-threads=POSIX_THREADS")
> > +                                 '())
>
> Does clisp only support threads on x86-64, or could it be enabled for
> some other architectures?



-- 

… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.

Comments

Guillaume Le Vaillant Sept. 4, 2023, 1:28 p.m. UTC | #1
The patch has been applied on the lisp-team branch, along with an update
for sbcl, if you want to test it.
Guillaume Le Vaillant Sept. 23, 2023, 9:15 a.m. UTC | #2
Merged in master at 4f35ff1275e05be31f5d41464ccf147e9dbfd016.
Closing.
diff mbox series

Patch

From a1501772832bf453bfdd241d6ff76ef4e1800c62 Mon Sep 17 00:00:00 2001
Message-Id: <a1501772832bf453bfdd241d6ff76ef4e1800c62.1693487783.git.sharlatanus@gmail.com>
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 3 Aug 2023 16:44:16 +0100
Subject: [PATCH] gnu: clisp: Add threads support on x84_64-linux.

Guix's build version of CLISP, fails to load bordeaux-threads:

Error while trying to load definition for system bordeaux-threads
      This implementation is unsupported.

This patch adds support for POSIX_THREADS on x86_64-linux
system.

* gnu/packages/lisp.scm (clisp)[arguments]: Add configuration options to
support threads on x86_64-linux system.

Reported and Co-Authored by Andrew Kravchuk <awkravchuk@gmail.com>
---
 gnu/packages/lisp.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 2f4fe6476d..867a5df496 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -17,7 +17,7 @@ 
 ;;; Copyright © 2019-2023 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
-;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
 ;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2023 Andrew Kravchuk <awkravchuk@gmail.com.
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -380,6 +381,10 @@  (define-public clisp
                                                      (%current-target-system)))
                                  '("CFLAGS=-falign-functions=4")
                                  '())
+                           ,@(if (target-x86?)
+                                 '("--enable-portability"
+                                   "--with-threads=POSIX_THREADS")
+                                 '())
                             "--with-dynamic-ffi"
                             "--with-dynamic-modules"
                             "--with-ffcall"

base-commit: 782cf09b84bc72514e89d783460ea98bc353bf6a
-- 
2.40.1