diff mbox series

[bug#44993] * gnu/packages/lisp-xyz.scm cl-log

Message ID CAO+9K5qOTRvNcuXBfoDi7Zm0Owg7CWgEaAQ=otYqEGn4pniZkQ@mail.gmail.com
State Accepted
Headers show
Series [bug#44993] * gnu/packages/lisp-xyz.scm cl-log | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Dec. 1, 2020, 2:55 p.m. UTC
Hi,

I would like to package https://github.com/dimitri/pgloader so I've
started from minor dependencies which are missing in upstream of Guix
packages.
It's my first time I've applied git patch and not sending ready to use script.

Comments

Guillaume Le Vaillant Dec. 5, 2020, 3:08 p.m. UTC | #1
I fixed the commit message and pushed as
65d3fab53aa1ac19c49f93d1d6b21df596ebeb0f. Thanks.
diff mbox series

Patch

From a9335a844b284f44e4a76306ae43c0ecd2beb24f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=23R=CE=BBatan?= <sharlatanus@gmail.com>
Date: Tue, 1 Dec 2020 14:39:02 +0000
Subject: [PATCH] * gnu/packages/lisp-xyz.scm

[new] cl-log
---
 gnu/packages/lisp-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2e6c059777..4e2b188ef1 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2020 Dimakis Dimakakos <me@bendersteed.tech>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
+;;; Copyright © 2020 sharlatan <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4282,6 +4283,41 @@  Python's WSGI and Ruby's Rack.")
 (define-public ecl-clack
   (sbcl-package->ecl-package sbcl-clack))
 
+(define-public sbcl-cl-log
+  (let ((commit "8f4b766d51e02245c310526cf1e4534ce634f837")
+        (revision "1"))
+    (package
+     (name "sbcl-cl-log")
+     (version "1.0.1")
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nicklevine/cl-log")
+             (commit commit)))
+       (sha256
+        (base32 "1r3z9swy1b59swvaa5b97is9ysrfmjvjjhhw56p7p5hqg93b92ak"))
+       (file-name (git-file-name "cl-log" version))))
+     (build-system asdf-build-system/sbcl)
+     (synopsis "Common Lisp general purpose logging utility")
+     (description "CL-LOG is a general purpose logging utility, loosely modelled
+in some respects after Gary King's Log5.  Its features include: logging to
+several destinations at once, via \"messengers\", each messenger is tailored to
+accept some log messages and reject others, and this tailoring can be changed
+on-the-fly, very rapid processing of messages which are rejected by all
+messengers, fully independent use of the utility by several different
+sub-systems in an application, support for messengers which cl:format text to a
+stream, support for messengers which do not invoke cl:format, timestamps in
+theory accurate to internal-time-units-per-second.")
+     (home-page "https://github.com/nicklevine/cl-log")
+     (license license:expat))))
+
+(define-public cl-log
+  (sbcl-package->cl-source-package sbcl-cl-log))
+
+(define-public ecl-log
+  (sbcl-package->ecl-package sbcl-cl-log))
+
 (define-public sbcl-log4cl
   (let ((commit "611e094458504b938d49de904eab141285328c7c")
         (revision "1"))
-- 
2.26.2