diff mbox series

[bug#48339] Attempt to fix missing dependencies for python-oslo.i18n failed with "too many heap sections"

Message ID CAO+9K5pOhtMNyTUkADa6F5_mW1wZyzCbWTKocWTn8PJqR1jkAw@mail.gmail.com
State New
Headers show
Series [bug#48339] Attempt to fix missing dependencies for python-oslo.i18n failed with "too many heap sections" | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher May 10, 2021, 9:34 p.m. UTC
Hi Guix team!

Package python-oslo.i18n is broken to build in upstream

--8<---------------cut here---------------start------------->8---
starting phase `check'
running "python setup.py" with command "test" and parameters ()
running test
Searching for bandit>=1.1.0
Reading https://pypi.org/simple/bandit/
/gnu/store/9w9jvy3bgjg4qaqmrij01nbppiccqr7c-python-3.8.2/lib/python3.8/site-packages/setuptools/dist.py:45:
DistDeprecationWarning: Do not call this function
  warnings.warn("Do not call this function", DistDeprecationWarning)
Download error on https://pypi.org/simple/bandit/: [Errno -2] Name or
service not known -- Some packages may not be found!
Couldn't find index page for 'bandit' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.org/simple/
Download error on https://pypi.org/simple/: [Errno -2] Name or service
not known -- Some packages may not be found!
No local packages or working download links found for bandit>=1.1.0
error: Could not find suitable distribution for
Requirement.parse('bandit>=1.1.0')
command "python" "-c" "import setuptools,
tokenize;__file__='setup.py';f=getattr(tokenize, 'open',
open)(__file__);code=f.read().replace('\\r\\n',
'\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed
with status 1
builder for `/gnu/store/ld9s5i13f8ja235nmr05fh7z837f51kw-python-oslo.i18n-3.20.0.drv'
failed with exit code 1
build of /gnu/store/ld9s5i13f8ja235nmr05fh7z837f51kw-python-oslo.i18n-3.20.0.drv
failed
View build log at
'/var/log/guix/drvs/ld/9s5i13f8ja235nmr05fh7z837f51kw-python-oslo.i18n-3.20.0.drv.bz2'.
guix build: error: build of
`/gnu/store/ld9s5i13f8ja235nmr05fh7z837f51kw-python-oslo.i18n-3.20.0.drv'
failed
--8<---------------cut here---------------end--------------->8---

My attempt to updte the package and add missing test dependencies was
failed with other issue:

--8<---------------cut here---------------start------------->8---
Too many heap sections: Increase MAXHINCR or MAX_HEAP_SECTS Aborted
--8<---------------cut here---------------end--------------->8---

I tried to apply this changes

--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.

Comments

Sharlatan Hellseher Feb. 8, 2024, 6:32 p.m. UTC | #1
Closing as never applied and not actual.
diff mbox series

Patch

From 0cf4299c07138b0c5d6003a2d4dd459d6361aac1 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 10 May 2021 22:32:20 +0100
Subject: [PATCH] oslo.i18n

---
 gnu/packages/openstack.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 54df08863e..a0193c2787 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -457,14 +457,14 @@  pipeline and used by various modules such as logging.")
 (define-public python-oslo.i18n
   (package
     (name "python-oslo.i18n")
-    (version "3.20.0")
+    (version "5.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "oslo.i18n" version))
        (sha256
         (base32
-         "0kjcdw4bk3mi4vqmqwhhq053kxbbbj05si6nwxd1pzx33z067ky3"))))
+         "0nq3dr2kbrawqvp9q9i8i44z9jliq98i2b9h4dsl6p7p60gbg11l"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-babel" ,python-babel)
@@ -474,7 +474,9 @@  pipeline and used by various modules such as logging.")
        ;; Tests
        ("python-mock" ,python-mock)
        ("python-mox3" ,python-mox3)
+       ("python-bandit" ,python-bandit)
        ("python-oslotest" ,python-oslotest)
+       ("python-oslo.config" ,python-oslo.config)
        ("python-testscenarios" ,python-testscenarios)))
     (home-page "https://launchpad.net/oslo")
     (synopsis "Oslo internationalization (i18n) library")
-- 
2.31.1