diff mbox series

[bug#45666] Add new variable guix/packages/image-processing.scm stiff

Message ID CAO+9K5p3HLOSCz199SAfD_sn1yaebNAnphJTL++4G23kp=ji2Q@mail.gmail.com
State Accepted
Headers show
Series [bug#45666] Add new variable guix/packages/image-processing.scm stiff | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Jan. 5, 2021, 12:36 a.m. UTC
Hi Guix Team,

I would like you to check this patch which would be one of the of
patches for Astronomy related software from
https://www.astromatic.net/software/

I've helped Oleh Malyi <astroclubzp@gmail.com> to make his first
package for the project. Is it possible to grant copyright of the
patch to him please?

Regards

Comments

Leo Famulari Jan. 5, 2021, 1:52 a.m. UTC | #1
On Tue, Jan 05, 2021 at 12:36:05AM +0000, Sharlatan Hellseher wrote:
> I would like you to check this patch which would be one of the of
> patches for Astronomy related software from
> https://www.astromatic.net/software/
> 
> I've helped Oleh Malyi <astroclubzp@gmail.com> to make his first
> package for the project. Is it possible to grant copyright of the
> patch to him please?

Of course!

> Subject: [PATCH] Add new gnu/packages/image-processing.scm stiff

I standardized the commit message...

> +    (synopsis "STIFF converts scientific FITS images to TIFF format")
> +    (description
> +     "STIFF is a program that converts scientific FITS images to the more
> +popular TIFF format for illustration purposes.")

Tweaked the synopses and description...

> +    (license license:gpl3)))

And changed this to gpl3+, because the C langugage source files'
copyright headers all say "either version 3 of the License, or (at your
option) any later version."

Pushed as commit 58a5746e7361c317e352920745fbe2ad01e2e802

https://git.savannah.gnu.org/cgit/guix.git/commit/?id=58a5746e7361c317e352920745fbe2ad01e2e802

Thanks a lot and welcome!
diff mbox series

Patch

From 7805607cf79058275e1bacd1cf32a8f9dcef8326 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=23R=CE=BBatan?= <sharlatanus@gmail.com>
Date: Tue, 5 Jan 2021 00:23:38 +0000
Subject: [PATCH] Add new gnu/packages/image-processing.scm stiff

---
 gnu/packages/image-processing.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 8d31029963..38cb954c07 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 Oleh Malyi <astroclubzp@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1064,3 +1065,26 @@  this project.
 Scan Tailer Advanced is a fork of Scan Tailer that merges Scan Tailor Featured
 and Scan Tailor Enhanced versions as well as including many more bug fixes.")
       (license license:gpl3+))))
+
+(define-public stiff
+  (package
+    (name "stiff")
+    (version "2.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.astromatic.net/download/stiff/stiff-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "14m92dskzw7bwsr64ha4p0mj3ndv13gwcbfic3qxrs3zq5353s7l"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libtiff" ,libtiff)
+       ("zlib" ,zlib)
+       ("libjpeg-turbo" ,libjpeg-turbo)))
+    (home-page "https://www.astromatic.net/software/stiff")
+    (synopsis "STIFF converts scientific FITS images to TIFF format")
+    (description
+     "STIFF is a program that converts scientific FITS images to the more
+popular TIFF format for illustration purposes.")
+    (license license:gpl3)))
-- 
2.26.2