diff mbox series

[bug#46161] Add new - stuff swarp weightwatcher

Message ID CAO+9K5p2-5kg1e-pxammh+1xsEfRCPt6NYSzhT1sMh2QH6u1xg@mail.gmail.com
State Accepted
Headers show
Series [bug#46161] Add new - stuff swarp weightwatcher | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Jan. 28, 2021, 9:23 p.m. UTC
Hi Guix team!

3 more small programs for astronomy without dependencies.

Comments

Guillaume Le Vaillant Jan. 29, 2021, 10:21 a.m. UTC | #1
Patches pushed as c21ad767d4368dbd9ff37a6fd5cdea8aa37fec57 and following
with a few modifications on some URIs and descriptions.
Thanks.
diff mbox series

Patch

From 9123526a823831ecf4288c198f8c07c3e3ce09ea Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 28 Jan 2021 21:15:04 +0000
Subject: [PATCH] gnu: Add stuff

* gnu/packages/astronomy.scm (stuff): New variable
---
 gnu/packages/astronomy.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4fce2d3530..6476a18d57 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -325,6 +325,26 @@  can be used to control telescopes over a serial port for tracking celestial
 objects.")
     (license license:gpl2+)))
 
+(define-public stuff
+  (package
+    (name "stuff")
+    (version "1.26.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.astromatic.net/download/"
+                           name "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1syibi3b86z9pikhicvkkmgxm916j732fdiw0agw0lq6z13fdcjm"))))
+    (build-system gnu-build-system)
+    (home-page "https://www.astromatic.net/software/stuff")
+    (synopsis "Catalogue simulation")
+    (description
+     "Stuff is a program that simulates \"perfect\" astronomical catalogues.  It
+generates object lists in ASCII which can read by the SkyMaker program to produce
+realistic astronomical fields.  Stuff is part of the EFIGI development project.")
+    (license license:gpl3+)))
+
 (define-public celestia
   (let ((commit "9dbdf29c4ac3d20afb2d9a80d3dff241ecf81dce"))
     (package
-- 
2.30.0