diff mbox series

[bug#46143] Add new skymaker

Message ID CAO+9K5oz3WSRAFuzU9svyLnxZigFiriJN7whhDyHjvq+pTe1pQ@mail.gmail.com
State Accepted
Headers show
Series [bug#46143] Add new skymaker | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Jan. 27, 2021, 8:04 p.m. UTC
Hi Guix team!

One more patch for astronomy software.

Comments

Guillaume Le Vaillant Jan. 28, 2021, 12:47 p.m. UTC | #1
Patch pushed as 33648567dd229b1302d2258e76d8b30593fedce6.
Thanks.
diff mbox series

Patch

From 29ae710d189764cbcaba8726b0b9901bc2d3e3e4 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 27 Jan 2021 20:00:55 +0000
Subject: [PATCH] gnu: Add skymaker

* gnu/packages/astronomy.scm (skymaker): New variable
---
 gnu/packages/astronomy.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 95231e1837..cd1a27477a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -229,6 +229,36 @@  large scale galaxy-survey data, it can perform reasonably well on moderately
 crowded star fields.")
     (license license:gpl3+)))
 
+(define-public skymaker
+  (package
+    (name "skymaker")
+    (version "3.10.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.astromatic.net/download/"
+                           name "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32 "03zvx7c89plp9559niqv5532r233kza3ir992rg3nxjksqmrqvx1"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        (string-append
+         "--with-fftw-libdir=" (assoc-ref %build-inputs "fftw") "/lib")
+        (string-append
+         "--with-fftw-incdir=" (assoc-ref %build-inputs "fftw") "/include"))))
+    (inputs
+     `(("fftw" ,fftwf)))
+    (home-page "https://www.astromatic.net/software/skymaker")
+    (synopsis "Image simulation")
+    (description
+     "SkyMaker is a program that simulates astronomical images. It accepts
+object lists in ASCII generated by the Stuff program to produce realistic
+astronomical fields.  SkyMaker is part of the EFIGI
+(https://www.astromatic.net/projects/efigi) development project.")
+    (license license:gpl3+)))
+
 (define-public stellarium
   (package
     (name "stellarium")
-- 
2.30.0